diff mbox series

[bug#61838,06/13] gnu: Add r-drat.

Message ID 20230227102850.18782-6-madalinionel.patrascu@mdc-berlin.de
State New
Headers show
Series [bug#61838,01/13] gnu: Add r-simplermarkdown. | expand

Commit Message

Mădălin Ionel Patrașcu Feb. 27, 2023, 10:28 a.m. UTC
* gnu/packages/cran.scm (r-drat): New variable.
---
 gnu/packages/cran.scm | 23 +++++++++++++++++++++++
 1 file changed, 23 insertions(+)
diff mbox series

Patch

diff --git a/gnu/packages/cran.scm b/gnu/packages/cran.scm
index 3784faa752..dbf98cdd81 100644
--- a/gnu/packages/cran.scm
+++ b/gnu/packages/cran.scm
@@ -6380,6 +6380,29 @@  (define-public r-lava
 variable models.")
     (license license:gpl3)))
 
+(define-public r-drat
+  (package
+    (name "r-drat")
+    (version "0.2.3")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (cran-uri "drat" version))
+       (sha256
+        (base32 "191yxlj9jccakmz27g7n9izfcy19kj3fgnw4w6zl9iq66787qpm6"))))
+    (properties `((upstream-name . "drat")))
+    (build-system r-build-system)
+    (native-inputs (list r-simplermarkdown))
+    (home-page "https://github.com/eddelbuettel/drat")
+    (synopsis "'Drat' R archive template")
+    (description
+     "This package helps you with creation and use of R repositories via helper
+functions to insert packages into a repository, and to add repository information
+to the current R session.  Two primary types of repositories are support: gh-pages
+at GitHub, as well as local repositories on either the same machine or a local
+network.  Drat is a recursive acronym: Drat R Archive Template.")
+    (license license:gpl2+)))
+
 (define-public r-drr
   (package
     (name "r-drr")