diff mbox series

[bug#55424,087/602] gnu: dot2tex: Update to 2.11.3.

Message ID 20220515044629.6843-87-maxim.cournoyer@gmail.com
State Accepted
Headers show
Series Purge Python 2 packages | expand

Commit Message

Maxim Cournoyer May 15, 2022, 4:37 a.m. UTC
* gnu/packages/graphviz.scm (dot2tex): Update to 2.11.3.
[arguments]: Remove python argument.
[phases]: New argument.
[native-inputs]: New field.
[inputs]: Move texlive-latex-preview to...
[propagated-inputs]: ... here.  Replace python2-pyparsing with
python-parsing.  Add texlive-bin, texlive-amsmath, texlive-latex-geometry,
texlive-latex-graphics, texlive-latex-base, texlive-latex-xkeyval,
texlive-pgf, texlive-pstricks and  texlive-xcolor.
---
 gnu/packages/graphviz.scm | 30 ++++++++++++++++++++++++++----
 1 file changed, 26 insertions(+), 4 deletions(-)
diff mbox series

Patch

diff --git a/gnu/packages/graphviz.scm b/gnu/packages/graphviz.scm
index 2a99c0988e..f2fd90e616 100644
--- a/gnu/packages/graphviz.scm
+++ b/gnu/packages/graphviz.scm
@@ -415,11 +415,33 @@  (define-public dot2tex
                 "1kp77wiv7b5qib82i3y3sn9r49rym43aaqm5aw1bwnzfbbq2m6i9"))))
     (build-system python-build-system)
     (arguments
-     `(#:python ,python-2))
-    (inputs
-     (list texlive-latex-preview graphviz))
+     (list
+      #:phases
+      #~(modify-phases %standard-phases
+          (replace 'check
+            (lambda* (#:key tests? #:allow-other-keys)
+              (when tests?
+                (invoke "pytest" "-vv" "tests"
+                        ;; The test_semicolon test fails for unknown reason
+                        ;; (see:
+                        ;; https://github.com/kjellmf/dot2tex/issues/94).
+                        "-k" "not test_semicolon")))))))
+    (native-inputs (list python-pytest))
+    (inputs (list graphviz))
     (propagated-inputs
-     (list python2-pyparsing))
+     (list python-pyparsing
+           ;; These TeX dependencies are propagated to make it easier to build
+           ;; the resulting generated TeX files, which \usepackage them.
+           texlive-bin
+           texlive-amsmath
+           texlive-latex-geometry
+           texlive-latex-graphics
+           texlive-latex-base
+           texlive-latex-preview
+           texlive-latex-xkeyval
+           texlive-pgf
+           texlive-pstricks
+           texlive-xcolor))
     (home-page "https://github.com/kjellmf/dot2tex")
     (synopsis "Graphviz to LaTeX converter")
     (description