diff mbox series

[bug#55424,066/602] gnu: Remove python2-fastlmm.

Message ID 20220515044629.6843-66-maxim.cournoyer@gmail.com
State Accepted
Headers show
Series Purge Python 2 packages | expand

Commit Message

Maxim Cournoyer May 15, 2022, 4:37 a.m. UTC
* gnu/packages/machine-learning.scm (python2-fastlmm): Delete variable.
---
 gnu/packages/machine-learning.scm | 32 -------------------------------
 1 file changed, 32 deletions(-)
diff mbox series

Patch

diff --git a/gnu/packages/machine-learning.scm b/gnu/packages/machine-learning.scm
index 02cd6b31aa..7b377c7d35 100644
--- a/gnu/packages/machine-learning.scm
+++ b/gnu/packages/machine-learning.scm
@@ -1415,38 +1415,6 @@  (define-public vowpal-wabbit
 interactive learning.")
     (license license:bsd-3)))
 
-(define-public python2-fastlmm
-  (package
-    (name "python2-fastlmm")
-    (version "0.2.21")
-    (source
-     (origin
-       (method url-fetch)
-       (uri (pypi-uri "fastlmm" version ".zip"))
-       (sha256
-        (base32
-         "1q8c34rpmwkfy3r4d5172pzdkpfryj561897z9r3x22gq7813x1m"))))
-    (build-system python-build-system)
-    (arguments
-     `(#:tests? #f ; some test files are missing
-       #:python ,python-2)) ; only Python 2.7 is supported
-    (propagated-inputs
-     (list python2-numpy
-           python2-scipy
-           python2-matplotlib
-           python2-pandas
-           python2-scikit-learn
-           python2-pysnptools))
-    (native-inputs
-     (list unzip python2-cython python2-mock python2-nose))
-    (home-page "http://research.microsoft.com/en-us/um/redmond/projects/mscompbio/fastlmm/")
-    (synopsis "Perform genome-wide association studies on large data sets")
-    (description
-     "FaST-LMM, which stands for Factored Spectrally Transformed Linear Mixed
-Models, is a program for performing both single-SNP and SNP-set genome-wide
-association studies (GWAS) on extremely large data sets.")
-    (license license:asl2.0)))
-
 (define-public python-hyperopt
   (package
     (name "python-hyperopt")