diff mbox series

[bug#55424,067/602] gnu: Remove python2-parameterized.

Message ID 20220515044629.6843-67-maxim.cournoyer@gmail.com
State Accepted
Headers show
Series Purge Python 2 packages | expand

Commit Message

Maxim Cournoyer May 15, 2022, 4:37 a.m. UTC
* gnu/packages/check.scm (python2-parameterized): Delete variable.
* gnu/packages/patches/python2-parameterized-docstring-test.patch: Delete file.
* gnu/local.mk (dist_patch_DATA): De-register it.
---
 gnu/local.mk                                   |  1 -
 gnu/packages/check.scm                         | 11 -----------
 .../python2-parameterized-docstring-test.patch | 18 ------------------
 3 files changed, 30 deletions(-)
 delete mode 100644 gnu/packages/patches/python2-parameterized-docstring-test.patch
diff mbox series

Patch

diff --git a/gnu/local.mk b/gnu/local.mk
index 4ef12fd68e..77f5ee9c33 100644
--- a/gnu/local.mk
+++ b/gnu/local.mk
@@ -1701,7 +1701,6 @@  dist_patch_DATA =						\
   %D%/packages/patches/python-mox3-python3.6-compat.patch	\
   %D%/packages/patches/python-typing-inspect-fix.patch		\
   %D%/packages/patches/python-packaging-test-arch.patch		\
-  %D%/packages/patches/python2-parameterized-docstring-test.patch	\
   %D%/packages/patches/python-paste-remove-timing-test.patch	\
   %D%/packages/patches/python-pycrypto-CVE-2013-7459.patch	\
   %D%/packages/patches/python-pycrypto-time-clock.patch		\
diff --git a/gnu/packages/check.scm b/gnu/packages/check.scm
index cffcd54623..f8b4fc7e2f 100644
--- a/gnu/packages/check.scm
+++ b/gnu/packages/check.scm
@@ -818,19 +818,8 @@  (define-public python-parameterized
     (description
      "Parameterized is a Python library that aims to fix parameterized testing
 for every Python test framework.  It supports nose, py.test, and unittest.")
-    (properties `((python2-variant . ,(delay python2-parameterized))))
     (license license:bsd-2)))
 
-(define-public python2-parameterized
-  (let ((base (package-with-python2 (strip-python2-variant
-                                     python-parameterized))))
-    (package/inherit
-     base
-     (source
-      (origin
-        (inherit (package-source base))
-        (patches (search-patches "python2-parameterized-docstring-test.patch")))))))
-
 (define-public python-minimock
   (package
     (name "python-minimock")
diff --git a/gnu/packages/patches/python2-parameterized-docstring-test.patch b/gnu/packages/patches/python2-parameterized-docstring-test.patch
deleted file mode 100644
index 14691e1904..0000000000
--- a/gnu/packages/patches/python2-parameterized-docstring-test.patch
+++ /dev/null
@@ -1,18 +0,0 @@ 
-Skip unicode docstring test, required when running on Python 2.
-
-See <https://github.com/wolever/parameterized/issues/44>.
-
---- a/parameterized/test.py
-+++ b/parameterized/test.py
-@@ -284,11 +284,6 @@
-             "        More" %(foo, )
-         )
- 
--    @parameterized.expand([param("foo")])
--    def test_unicode_docstring(self, foo):
--        u"""Döcumentation."""
--        self._assert_docstring(u"Döcumentation [with foo=%r]." %(foo, ))
--
-     @parameterized.expand([param("foo", )])
-     def test_default_values_get_correct_value(self, foo, bar=12):
-         """Documentation"""