diff mbox series

[bug#55424,064/602] gnu: Remove python2-statsmodels.

Message ID 20220515044629.6843-64-maxim.cournoyer@gmail.com
State Accepted
Headers show
Series Purge Python 2 packages | expand

Commit Message

Maxim Cournoyer May 15, 2022, 4:37 a.m. UTC
* gnu/packages/statistics.scm (python2-statsmodels): Delete variable.
---
 gnu/packages/statistics.scm | 21 ---------------------
 1 file changed, 21 deletions(-)
diff mbox series

Patch

diff --git a/gnu/packages/statistics.scm b/gnu/packages/statistics.scm
index 244a2f3ecb..891c2b804c 100644
--- a/gnu/packages/statistics.scm
+++ b/gnu/packages/statistics.scm
@@ -2068,27 +2068,6 @@  (define-public python-statsmodels
 inference for statistical models.")
     (license license:bsd-3)))
 
-(define-public python2-statsmodels
-  (let ((stats (package-with-python2 python-statsmodels)))
-    (package/inherit stats
-      ;; Version 0.11.1 and later does not work with Python 2.  It may build
-      ;; fine but loading modules fails.
-      (version "0.9.0")
-      (source
-       (origin
-         (method url-fetch)
-         (uri (pypi-uri "statsmodels" version))
-         (sha256
-          (base32
-           "0fxs8a7sp4d7jvqlm36yi45i2d28kjfvraf9q8i9jr1chhxgjqb4"))))
-      (propagated-inputs
-       `(("python2-pytz" ,python2-pytz)
-         ("python2-numpy" ,python2-numpy)
-         ("python2-scipy" ,python2-scipy)
-         ("python2-pandas" ,python2-pandas)
-         ("python2-patsy" ,python2-patsy)
-         ("python2-matplotlib" ,python2-matplotlib))))))
-
 (define-public r-coda
   (package
     (name "r-coda")