diff mbox series

[bug#55424,026/602] gnu: Remove python2-warpedlmm.

Message ID 20220515044629.6843-26-maxim.cournoyer@gmail.com
State Accepted
Headers show
Series Purge Python 2 packages | expand

Commit Message

Maxim Cournoyer May 15, 2022, 4:36 a.m. UTC
* gnu/packages/bioinformatics.scm (python2-warpedlmm): Delete variable.
---
 gnu/packages/bioinformatics.scm | 41 ---------------------------------
 1 file changed, 41 deletions(-)
diff mbox series

Patch

diff --git a/gnu/packages/bioinformatics.scm b/gnu/packages/bioinformatics.scm
index c70b9e3aa7..b0ad03612e 100644
--- a/gnu/packages/bioinformatics.scm
+++ b/gnu/packages/bioinformatics.scm
@@ -5365,47 +5365,6 @@  (define-public python2-pbcore
 files and writing bioinformatics applications.")
     (license license:bsd-3)))
 
-(define-public python2-warpedlmm
-  (package
-    (name "python2-warpedlmm")
-    (version "0.21")
-    (source
-     (origin
-       (method url-fetch)
-       (uri (pypi-uri "WarpedLMM" version ".zip"))
-       (sha256
-        (base32
-         "1agfz6zqa8nc6cw47yh0s3y14gkpa9wqazwcj7mwwj3ffnw39p3j"))))
-    (build-system python-build-system)
-    (arguments
-     `(#:python ,python-2  ; requires Python 2.7
-       #:tests? #f ; test data are not included
-       #:phases
-       (modify-phases %standard-phases
-         (add-after 'unpack 'use-weave
-           (lambda _
-             (substitute* "warpedlmm/util/linalg.py"
-               (("from scipy import linalg, weave")
-                "from scipy import linalg\nimport weave"))
-             #t)))))
-    (propagated-inputs
-     (list python2-scipy
-           python2-numpy
-           python2-matplotlib
-           python2-fastlmm
-           python2-pandas
-           python2-pysnptools
-           python2-weave))
-    (native-inputs
-     (list python2-mock python2-nose unzip))
-    (home-page "https://github.com/PMBio/warpedLMM")
-    (synopsis "Implementation of warped linear mixed models")
-    (description
-     "WarpedLMM is a Python implementation of the warped linear mixed model,
-which automatically learns an optimal warping function (or transformation) for
-the phenotype as it models the data.")
-    (license license:asl2.0)))
-
 (define-public prank
   (package
     (name "prank")