diff mbox series

[bug#55424,062/602] gnu: Remove python2-pandas.

Message ID 20220515044629.6843-62-maxim.cournoyer@gmail.com
State Accepted
Headers show
Series Purge Python 2 packages | expand

Commit Message

Maxim Cournoyer May 15, 2022, 4:37 a.m. UTC
* gnu/packages/python-science.scm (python2-pandas): Delete variable.
(python-pandas): Delete related python2-variant property.
---
 gnu/packages/python-science.scm | 98 ---------------------------------
 1 file changed, 98 deletions(-)
diff mbox series

Patch

diff --git a/gnu/packages/python-science.scm b/gnu/packages/python-science.scm
index bf7c7ce45f..b3f39fd19d 100644
--- a/gnu/packages/python-science.scm
+++ b/gnu/packages/python-science.scm
@@ -488,106 +488,8 @@  (define-public python-pandas
 multidimensional, potentially heterogeneous) and time series data both easy
 and intuitive.  It aims to be the fundamental high-level building block for
 doing practical, real world data analysis in Python.")
-    (properties `((python2-variant . ,(delay python2-pandas))))
     (license license:bsd-3)))
 
-;; Pandas 0.24.x are the last versions that support Python 2.
-(define-public python2-pandas
-  (let ((pandas (package-with-python2
-                 (strip-python2-variant python-pandas))))
-    (package
-      (inherit pandas)
-      (version "0.24.2")
-      (source (origin
-                (method url-fetch)
-                (uri (pypi-uri "pandas" version))
-                (sha256
-                 (base32
-                  "18imlm8xbhcbwy4wa957a1fkamrcb0z988z006jpfda3ki09z4ag"))
-                (modules '((guix build utils)))
-                (snippet
-                 '(begin
-                    ;; Adjust for renamed error message in Python 2.7.17.  Taken
-                    ;; from <https://github.com/pandas-dev/pandas/pull/29294>.
-                    (substitute* "pandas/io/parsers.py"
-                      (("if 'NULL byte' in msg:")
-                       "if 'NULL byte' in msg or 'line contains NUL' in msg:"))))))
-      (arguments
-       `(#:modules ((guix build utils)
-                    (guix build python-build-system)
-                    (ice-9 ftw)
-                    (srfi srfi-26))
-         #:python ,python-2
-         #:phases
-         (modify-phases %standard-phases
-           (add-after 'unpack 'patch-which
-             (lambda* (#:key inputs #:allow-other-keys)
-               (let ((which (assoc-ref inputs "which")))
-                 (substitute* "pandas/io/clipboard/__init__.py"
-                   (("^CHECK_CMD = .*")
-                    (string-append "CHECK_CMD = \"" which "\"\n"))))))
-           (replace 'check
-             (lambda _
-               (let ((build-directory
-                      (string-append
-                       (getcwd) "/build/"
-                       (car (scandir "build"
-                                     (cut string-prefix? "lib." <>))))))
-                 ;; Disable the "strict data files" option which causes
-                 ;; the build to error out if required data files are
-                 ;; not available (as is the case with PyPI archives).
-                 (substitute* "setup.cfg"
-                   (("addopts = --strict-data-files") "addopts = "))
-                 (with-directory-excursion build-directory
-                   ;; Delete tests that require "moto" which is not yet
-                   ;; in Guix.
-                   (for-each delete-file
-                             '("pandas/tests/io/conftest.py"
-                               "pandas/tests/io/json/test_compression.py"
-                               "pandas/tests/io/parser/test_network.py"
-                               "pandas/tests/io/test_parquet.py"))
-                   (invoke "pytest" "-vv" "pandas" "--skip-slow"
-                           "--skip-network" "-k"
-                           ;; XXX: Due to the deleted tests above.
-                           "not test_read_s3_jsonl"))))))))
-      (propagated-inputs
-       (list python2-numpy python2-openpyxl python2-pytz python2-dateutil
-             python2-xlrd))
-      (inputs
-       (list which))
-      (native-inputs
-       (list python2-cython
-             python2-beautifulsoup4
-             python2-lxml
-             python2-html5lib
-             python2-nose
-             python2-pytest
-             python2-pytest-mock)))))
-
-(define-public python2-pyflow
-  (package
-    (name "python2-pyflow")
-    (version "1.1.20")
-    (source (origin
-              (method url-fetch)
-              (uri (string-append
-                    "https://github.com/Illumina/pyflow/releases/download/v"
-                    version "/pyflow-" version ".tar.gz"))
-              (sha256
-               (base32
-                "1bvfvviw58cndyn862qnv9nj3d9cd3a0dm4vc4sd9vwq8a6z1riv"))))
-    (build-system python-build-system)
-    (arguments
-     `(#:tests? #f ; There is no test suite.
-       ;; There is no official Python 3-compatible version and upstream is
-       ;; dead. See https://github.com/Illumina/pyflow/issues/20.
-       #:python ,python-2))
-    (home-page "https://illumina.github.io/pyflow/")
-    (synopsis "Tool to manage tasks in a task dependency graph")
-    (description "This package is a Python module to manage tasks in the
-context of a task dependency graph.  It has some similarities to make.")
-    (license license:bsd-2)))
-
 (define-public python-pythran
   (package
     (name "python-pythran")