diff mbox series

[bug#60075,08/58] gnu: Remove julia-identityranges.

Message ID 2d0acc3d51db5f3aa590b3f86df46a6fb1d32bf8.1671049573.git.efraim@flashner.co.il
State New
Headers show
Series New julia patches | expand

Commit Message

Efraim Flashner Dec. 14, 2022, 8:35 p.m. UTC
* gnu/packages/julia-xyz.scm (julia-identityranges): Delete variable.
---
 gnu/packages/julia-xyz.scm | 26 --------------------------
 1 file changed, 26 deletions(-)

Comments

Simon Tournier Dec. 19, 2022, 6:32 p.m. UTC | #1
Hi,

On Wed, 14 Dec 2022 at 22:35, Efraim Flashner <efraim@flashner.co.il> wrote:
> * gnu/packages/julia-xyz.scm (julia-identityranges): Delete variable.

Is it an issue to keep it?


Cheers,
simon
Efraim Flashner Dec. 21, 2022, 5:09 p.m. UTC | #2
On Mon, Dec 19, 2022 at 07:32:51PM +0100, zimoun wrote:
> Hi,
> 
> On Wed, 14 Dec 2022 at 22:35, Efraim Flashner <efraim@flashner.co.il> wrote:
> > * gnu/packages/julia-xyz.scm (julia-identityranges): Delete variable.
> 
> Is it an issue to keep it?

It doesn't build with the upgrade to julia. There's also an open bug
report with them to deprecate it in favor of Base.IdentityUnitRange.
diff mbox series

Patch

diff --git a/gnu/packages/julia-xyz.scm b/gnu/packages/julia-xyz.scm
index 6ec4df3486..845e71f0f2 100644
--- a/gnu/packages/julia-xyz.scm
+++ b/gnu/packages/julia-xyz.scm
@@ -2475,32 +2475,6 @@  (define-public julia-http
 implementing both a client and a server.")
     (license license:expat)))
 
-(define-public julia-identityranges
-  (package
-    (name "julia-identityranges")
-    (version "0.3.1")
-    (source
-      (origin
-        (method git-fetch)
-        (uri (git-reference
-               (url "https://github.com/JuliaArrays/IdentityRanges.jl")
-               (commit (string-append "v" version))))
-        (file-name (git-file-name name version))
-        (sha256
-         (base32 "0jvl4xn8f8k70sn473li5q62wbiycl5qi25b5k456h3a0j1lbiml"))))
-    (build-system julia-build-system)
-    (propagated-inputs
-     (list julia-offsetarrays))
-    (home-page "https://github.com/JuliaArrays/IdentityRanges.jl")
-    (synopsis "Ranges that preserve indices of views")
-    (description "@code{IdentityRanges} are Julia-language a helper type for
-creating \"views\" of arrays.  They are a custom type of AbstractUnitRange that
-makes it easy to preserve the indices of array views.  The key property of an
-@code{IdentityRange r} is that @code{r[i] == i} (hence the name of the
-type/package), and that they support arbitrary start/stop indices (i.e., not
-just starting at 1).")
-    (license license:expat)))
-
 (define-public julia-ifelse
   (package
     (name "julia-ifelse")