diff mbox series

[bug#60075,04/58] gnu: julia-mappedarrays: Update to 0.4.1.

Message ID 3a81daf5853c3fb97866cb6a11c2fcdf40a59a25.1671049573.git.efraim@flashner.co.il
State New
Headers show
Series New julia patches | expand

Commit Message

Efraim Flashner Dec. 14, 2022, 8:35 p.m. UTC
* gnu/packages/julia-xyz.scm (julia-mappedarrays): Update to 0.4.1.
[source]: Add snippet to fix deprecation warning and to fix the
testsuite.
[arguments]: Add 'adjust-tests phase to skip a test and absorb the
i686-linux specific phase 'fix-tests-int32-i686.
[native-inputs]: Remove julia-colortypes. Add julia-colors.
---
 gnu/packages/julia-xyz.scm | 34 ++++++++++++++++++++++++----------
 1 file changed, 24 insertions(+), 10 deletions(-)
diff mbox series

Patch

diff --git a/gnu/packages/julia-xyz.scm b/gnu/packages/julia-xyz.scm
index b31ef2faac..01a3569e8d 100644
--- a/gnu/packages/julia-xyz.scm
+++ b/gnu/packages/julia-xyz.scm
@@ -3438,7 +3438,7 @@  (define-public julia-macrotools
 (define-public julia-mappedarrays
   (package
     (name "julia-mappedarrays")
-    (version "0.4.0")
+    (version "0.4.1")
     (source
       (origin
         (method git-fetch)
@@ -3447,22 +3447,36 @@  (define-public julia-mappedarrays
                (commit (string-append "v" version))))
         (file-name (git-file-name name version))
         (sha256
-         (base32 "0l5adird8m1cmnsxwhzi5hcr7q9bm1rf7a6018zc7kcn2yxdshy3"))))
+         (base32 "08kb28dv1zzqbbxblhyllgs4sjxyp76dgjqhdizcq4zg4i1kls6p"))
+        (snippet
+         #~(begin
+             (use-modules (guix build utils))
+             ;; Fix deprecation warning
+             ;; https://github.com/JuliaArrays/MappedArrays.jl/pull/51
+             (substitute* "src/MappedArrays.jl"
+               (("Vararg\\{<:AbstractArray") "Vararg{AbstractArray"))
+             ;; Fix test failures
+             ;; https://github.com/JuliaArrays/MappedArrays.jl/pull/50
+             (substitute* "test/runtests.jl"
+               (("_zero\\(x\\) = x > 0 \\? x : 0")
+                "_zero(x) = ismissing(x) ? x : (x > 0 ? x : 0)"))))))
     (build-system julia-build-system)
     (arguments
      (list
       #:phases
-      (if (target-64bit?)
-          #~%standard-phases
-          #~(modify-phases %standard-phases
-              (add-after 'unpack 'fix-tests-int32-i686
-                (lambda _
-                  (substitute* "test/runtests.jl"
-                    (("Int64") "Int32"))))))))
+      #~(modify-phases %standard-phases
+          (add-after 'unpack 'adjust-tests
+            (lambda _
+              (substitute* "test/runtests.jl"
+                ((".*@test_throws ErrorException b.*") ""))
+
+              (when #$(not (target-64bit?))
+                (substitute* "test/runtests.jl"
+                  (("Int64") "Int32"))))))))
     (propagated-inputs
      (list julia-fixedpointnumbers))
     (native-inputs
-     (list julia-colortypes
+     (list julia-colors
            julia-fixedpointnumbers
            julia-offsetarrays))
     (home-page "https://github.com/JuliaArrays/MappedArrays.jl")