diff mbox series

[bug#60075,42/58] gnu: julia-plotutils: Update to 1.2.0.

Message ID d68a6ef7dec69d34958e9dd073c9bee76b0a4257.1671049574.git.efraim@flashner.co.il
State New
Headers show
Series New julia patches | expand

Commit Message

Efraim Flashner Dec. 14, 2022, 8:35 p.m. UTC
* gnu/packages/julia-xyz.scm (julia-plotutils): Update to 1.2.0.
[arguments]: Add a phase to adjust the test suite.
---
 gnu/packages/julia-xyz.scm | 13 +++++++++++--
 1 file changed, 11 insertions(+), 2 deletions(-)
diff mbox series

Patch

diff --git a/gnu/packages/julia-xyz.scm b/gnu/packages/julia-xyz.scm
index c3d6d642c1..4ef88ad850 100644
--- a/gnu/packages/julia-xyz.scm
+++ b/gnu/packages/julia-xyz.scm
@@ -4307,7 +4307,7 @@  (define-public julia-plotthemes
 (define-public julia-plotutils
   (package
     (name "julia-plotutils")
-    (version "1.0.15")
+    (version "1.2.0")
     (source
       (origin
         (method git-fetch)
@@ -4316,8 +4316,17 @@  (define-public julia-plotutils
                (commit (string-append "v" version))))
         (file-name (git-file-name name version))
         (sha256
-         (base32 "12aw5gkkcfhpczv2w510k65w1j0hjnh825ihimi223v8plsi5105"))))
+         (base32 "1yml9ayaniqnzx5r8sfjckifcm99ck7qhc19cd8fs0bwzkh7nza7"))))
     (build-system julia-build-system)
+    (arguments
+     (list
+       #:phases
+       #~(modify-phases %standard-phases
+           (add-after 'unpack 'adjust-test-suite
+             (lambda _
+               (substitute* "test/runtests.jl"
+                 (("(@test_throws) ErrorException (.*notacolor)" _ @test notacolor)
+                  (string-append @test " ArgumentError " notacolor))))))))
     (propagated-inputs
      (list julia-colors
            julia-colorschemes