diff mbox series

[bug#60075,11/58] gnu: Add julia-changesofvariables.

Message ID ef8875bb78df859779fb76aa4062b510a216cfae.1671049573.git.efraim@flashner.co.il
State New
Headers show
Series New julia patches | expand

Commit Message

Efraim Flashner Dec. 14, 2022, 8:35 p.m. UTC
* gnu/packages/julia-xyz.scm (julia-changesofvariables): New variable.
---
 gnu/packages/julia-xyz.scm | 27 +++++++++++++++++++++++++++
 1 file changed, 27 insertions(+)

Comments

Simon Tournier Dec. 19, 2022, 6:34 p.m. UTC | #1
Hi,

On Wed, 14 Dec 2022 at 22:35, Efraim Flashner <efraim@flashner.co.il> wrote:
> * gnu/packages/julia-xyz.scm (julia-changesofvariables): New variable.

> +    (description "ChangesOfVariables.jl defines functionality to calculate
> +volume element changes for functions that perform a change of variables (like
> +coordinate transformations).")
> +    (license license:expat)))

Well, to keep consistency with the rest, I suggest to apply @code or to
start with «This package defines…».


Cheers,
simon
Efraim Flashner Dec. 21, 2022, 5:09 p.m. UTC | #2
On Mon, Dec 19, 2022 at 07:34:37PM +0100, zimoun wrote:
> Hi,
> 
> On Wed, 14 Dec 2022 at 22:35, Efraim Flashner <efraim@flashner.co.il> wrote:
> > * gnu/packages/julia-xyz.scm (julia-changesofvariables): New variable.
> 
> > +    (description "ChangesOfVariables.jl defines functionality to calculate
> > +volume element changes for functions that perform a change of variables (like
> > +coordinate transformations).")
> > +    (license license:expat)))
> 
> Well, to keep consistency with the rest, I suggest to apply @code or to
> start with «This package defines…».

Changed it to "This package defines ..."
diff mbox series

Patch

diff --git a/gnu/packages/julia-xyz.scm b/gnu/packages/julia-xyz.scm
index 90b2678815..c3b12ee90c 100644
--- a/gnu/packages/julia-xyz.scm
+++ b/gnu/packages/julia-xyz.scm
@@ -822,6 +822,33 @@  (define-public julia-chainrulestestutils
 dependencies, while keeping @code{ChainRulesCore.jl} as light-weight as possible.")
     (license license:expat)))
 
+(define-public julia-changesofvariables
+  (package
+    (name "julia-changesofvariables")
+    (version "0.1.4")
+    (source
+     (origin
+       (method git-fetch)
+       (uri (git-reference
+             (url "https://github.com/JuliaMath/ChangesOfVariables.jl")
+             (commit (string-append "v" version))))
+       (file-name (git-file-name name version))
+       (sha256
+        (base32 "1migyhiqr1rq496302wlkb0s5l8zwqs97ajfkip0jzpvrk2s2xxy"))))
+    (build-system julia-build-system)
+    (arguments
+     ;; Pulls in ForwardDiff, would have a cyclical
+     ;; dependency with LogExpFunctions.
+     (list #:tests? #f))
+    (propagated-inputs
+     (list julia-chainrulescore))
+    (home-page "https://github.com/JuliaMath/ChangesOfVariables.jl")
+    (synopsis "Interface for transformation functions in Julia")
+    (description "ChangesOfVariables.jl defines functionality to calculate
+volume element changes for functions that perform a change of variables (like
+coordinate transformations).")
+    (license license:expat)))
+
 (define-public julia-codeczlib
   (package
     (name "julia-codeczlib")