diff mbox series

[bug#60075,44/58] gnu: julia-indexablebitvectors: Limit to 64-bit systems.

Message ID ce3eb363cbd85c064a8a8aebac5e99e1c40edec4.1671049574.git.efraim@flashner.co.il
State New
Headers show
Series New julia patches | expand

Commit Message

Efraim Flashner Dec. 14, 2022, 8:35 p.m. UTC
* gnu/packages/julia-xyz.scm (julia-indexablebitvectors)
[supported-systems]: New field.
---
 gnu/packages/julia-xyz.scm | 1 +
 1 file changed, 1 insertion(+)

Comments

Simon Tournier Dec. 19, 2022, 6:43 p.m. UTC | #1
Hi,

On Wed, 14 Dec 2022 at 22:35, Efraim Flashner <efraim@flashner.co.il> wrote:
> * gnu/packages/julia-xyz.scm (julia-indexablebitvectors)
> [supported-systems]: New field.

> +    (supported-systems %64bit-supported-systems)

It means that julia-bioalignments will not build for non-64bit system.

Well, is it because upstream does not support other than 64bits?


Cheers,
simon
Efraim Flashner Dec. 21, 2022, 5:10 p.m. UTC | #2
On Mon, Dec 19, 2022 at 07:43:06PM +0100, zimoun wrote:
> Hi,
> 
> On Wed, 14 Dec 2022 at 22:35, Efraim Flashner <efraim@flashner.co.il> wrote:
> > * gnu/packages/julia-xyz.scm (julia-indexablebitvectors)
> > [supported-systems]: New field.
> 
> > +    (supported-systems %64bit-supported-systems)
> 
> It means that julia-bioalignments will not build for non-64bit system.
> 
> Well, is it because upstream does not support other than 64bits?

There's a bunch of bitwise math that expects 64-bit ints and things like
that. I'll add a comment above the supported-systems field.
diff mbox series

Patch

diff --git a/gnu/packages/julia-xyz.scm b/gnu/packages/julia-xyz.scm
index 2b4e8e2579..ed7c62c0be 100644
--- a/gnu/packages/julia-xyz.scm
+++ b/gnu/packages/julia-xyz.scm
@@ -2910,6 +2910,7 @@  (define-public julia-indexablebitvectors
 index of i-th occurrence of @code{b} in @code{bv}.
 @end itemize
 and other shortcuts or types.")
+    (supported-systems %64bit-supported-systems)
     (license license:expat)))
 
 (define-public julia-indexing