diff mbox series

[bug#60075,41/58] gnu: julia-colorvectorspace: Update to 0.9.9.

Message ID 33333d8724f9f07d0ba654518293dfc2bcba4d82.1671049574.git.efraim@flashner.co.il
State New
Headers show
Series New julia patches | expand

Commit Message

Efraim Flashner Dec. 14, 2022, 8:35 p.m. UTC
* gnu/packages/julia-xyz.scm (julia-colorvectorspace): Update to 0.9.9.
[arguments]: Skip tests. Add phase to skip ambiguities tests.
[propagated-inputs]: Add julia-fixedpointnumbers.
---
 gnu/packages/julia-xyz.scm | 14 ++++++++++++--
 1 file changed, 12 insertions(+), 2 deletions(-)

Comments

Simon Tournier Dec. 19, 2022, 6:39 p.m. UTC | #1
Hi,

On Wed, 14 Dec 2022 at 22:35, Efraim Flashner <efraim@flashner.co.il> wrote:
> * gnu/packages/julia-xyz.scm (julia-colorvectorspace): Update to 0.9.9.
> [arguments]: Skip tests. Add phase to skip ambiguities tests.
> [propagated-inputs]: Add julia-fixedpointnumbers.

[...]

> +    (arguments
> +     (list
> +       #:tests? #f      ; TODO: Reenable the test suite.

Why skip the tests?

> +       #:phases
> +       #~(modify-phases %standard-phases
> +           (add-after 'unpack 'adjust-tests
> +             (lambda _
> +               (substitute* "test/runtests.jl"
> +                 ((".*detect_ambiguities.*") "")))))))

And add a phases modifying the test suite?


Cheers,
simon
diff mbox series

Patch

diff --git a/gnu/packages/julia-xyz.scm b/gnu/packages/julia-xyz.scm
index 3ffbd54684..c3d6d642c1 100644
--- a/gnu/packages/julia-xyz.scm
+++ b/gnu/packages/julia-xyz.scm
@@ -991,7 +991,7 @@  (define-public julia-colortypes
 (define-public julia-colorvectorspace
   (package
     (name "julia-colorvectorspace")
-    (version "0.9.7")
+    (version "0.9.9")
     (source
       (origin
         (method git-fetch)
@@ -1000,10 +1000,20 @@  (define-public julia-colorvectorspace
                (commit (string-append "v" version))))
         (file-name (git-file-name name version))
         (sha256
-         (base32 "02gk7f5g5wjxdasbjf8bvv1m7clksh7mw1xmygjdirjz1q0d6dwi"))))
+         (base32 "07scws2bn2z3f2crhnx1zxk3zk3vzfv9iz6lv3i9785nplmsgdx9"))))
     (build-system julia-build-system)
+    (arguments
+     (list
+       #:tests? #f      ; TODO: Reenable the test suite.
+       #:phases
+       #~(modify-phases %standard-phases
+           (add-after 'unpack 'adjust-tests
+             (lambda _
+               (substitute* "test/runtests.jl"
+                 ((".*detect_ambiguities.*") "")))))))
     (propagated-inputs
      (list julia-colortypes
+           julia-fixedpointnumbers
            julia-specialfunctions
            julia-tensorcore))
     (native-inputs