diff mbox series

[bug#60075,10/58] gnu: Add julia-inversefunctions.

Message ID 6b8cfa6a1902ffb6729fd20351dea0cf07f445bf.1671049573.git.efraim@flashner.co.il
State New
Headers show
Series New julia patches | expand

Commit Message

Efraim Flashner Dec. 14, 2022, 8:35 p.m. UTC
* gnu/packages/julia-xyz.scm (julia-inversefunctions): New variable.
---
 gnu/packages/julia-xyz.scm | 22 ++++++++++++++++++++++
 1 file changed, 22 insertions(+)

Comments

Simon Tournier Dec. 19, 2022, 6:13 p.m. UTC | #1
Hi,

On Wed, 14 Dec 2022 at 22:35, Efraim Flashner <efraim@flashner.co.il> wrote:
> * gnu/packages/julia-xyz.scm (julia-inversefunctions): New variable.

[...]

> +    (synopsis "Interface for function inversion in Julia")

I would remove « in Julia ».

> +    (description
> +     "@code{InverseFunctions.jl} defines an interface to invert functions.")
> +    (license license:expat)))

I think this description:

--8<---------------cut here---------------start------------->8---
+    (description "This package provides an interface to invert functions.  It
+is a lightweight package.")
--8<---------------cut here---------------end--------------->8---


Cheers,
simon
Efraim Flashner Dec. 21, 2022, 5:09 p.m. UTC | #2
On Mon, Dec 19, 2022 at 07:13:55PM +0100, zimoun wrote:
> Hi,
> 
> On Wed, 14 Dec 2022 at 22:35, Efraim Flashner <efraim@flashner.co.il> wrote:
> > * gnu/packages/julia-xyz.scm (julia-inversefunctions): New variable.
> 
> [...]
> 
> > +    (synopsis "Interface for function inversion in Julia")
> 
> I would remove « in Julia ».

done

> > +    (description
> > +     "@code{InverseFunctions.jl} defines an interface to invert functions.")
> > +    (license license:expat)))
> 
> I think this description:
> 
> --8<---------------cut here---------------start------------->8---
> +    (description "This package provides an interface to invert functions.  It
> +is a lightweight package.")
> --8<---------------cut here---------------end--------------->8---

I used the first sentence. It may be a lightweight package but it is a
little too like marketing for me.
diff mbox series

Patch

diff --git a/gnu/packages/julia-xyz.scm b/gnu/packages/julia-xyz.scm
index 33856fcf32..90b2678815 100644
--- a/gnu/packages/julia-xyz.scm
+++ b/gnu/packages/julia-xyz.scm
@@ -3060,6 +3060,28 @@  (define-public julia-intervaltrees
 The type @code{K} may be any ordered type.")
       (license license:expat))))
 
+(define-public julia-inversefunctions
+  (package
+    (name "julia-inversefunctions")
+    (version "0.1.8")
+    (source
+      (origin
+        (method git-fetch)
+        (uri (git-reference
+               (url "https://github.com/JuliaMath/InverseFunctions.jl")
+               (commit (string-append "v" version))))
+        (file-name (git-file-name name version))
+        (sha256
+         (base32 "05g9f6i735x7syfr56l4yf4fy71kgdisjc6cfxi4jkf46iq86a69"))))
+    (build-system julia-build-system)
+    (native-inputs
+     (list julia-documenter))
+    (home-page "https://github.com/JuliaMath/InverseFunctions.jl")
+    (synopsis "Interface for function inversion in Julia")
+    (description
+     "@code{InverseFunctions.jl} defines an interface to invert functions.")
+    (license license:expat)))
+
 (define-public julia-invertedindices
   (package
     (name "julia-invertedindices")