diff mbox series

[bug#60075,06/58] gnu: julia-imagebase: Update to 0.1.5.

Message ID ff43823a8e815eef5e8abf522afd631f797d9fdb.1671049573.git.efraim@flashner.co.il
State New
Headers show
Series New julia patches | expand

Commit Message

Efraim Flashner Dec. 14, 2022, 8:35 p.m. UTC
* gnu/packages/julia-xyz.scm (julia-imagebase): Update to 0.1.5.
---
 gnu/packages/julia-xyz.scm | 15 ++++++++++-----
 1 file changed, 10 insertions(+), 5 deletions(-)

Comments

Simon Tournier Dec. 19, 2022, 6:32 p.m. UTC | #1
Hi,

On Wed, 14 Dec 2022 at 22:35, Efraim Flashner <efraim@flashner.co.il> wrote:
> * gnu/packages/julia-xyz.scm (julia-imagebase): Update to 0.1.5.

>      (arguments
>       (list #:tests? #f))    ; Cycle with ImageMagick.jl.

[...]

>      ;(native-inputs
> -    ; `(("julia-imagemagick" ,julia-imagemagick)
> -    ;   ("julia-offsetarrays" ,julia-offsetarrays)
> -    ;   ("julia-testimages" ,julia-testimages)))
> +    ; (list julia-aqua
> +    ;       julia-documenter
> +    ;       julia-imagefiltering
> +    ;       julia-imageio
> +    ;       julia-imagemagick
> +    ;       julia-offsetarrays
> +    ;       jula-statistics
> +    ;       julia-testimages))

Is this change useful?  Is it for maintaining an accurate list for
passing tests if we cut the cycle?


Cheers,
simon
Efraim Flashner Dec. 21, 2022, 5:09 p.m. UTC | #2
On Mon, Dec 19, 2022 at 07:32:00PM +0100, zimoun wrote:
> Hi,
> 
> On Wed, 14 Dec 2022 at 22:35, Efraim Flashner <efraim@flashner.co.il> wrote:
> > * gnu/packages/julia-xyz.scm (julia-imagebase): Update to 0.1.5.
> 
> >      (arguments
> >       (list #:tests? #f))    ; Cycle with ImageMagick.jl.
> 
> [...]
> 
> >      ;(native-inputs
> > -    ; `(("julia-imagemagick" ,julia-imagemagick)
> > -    ;   ("julia-offsetarrays" ,julia-offsetarrays)
> > -    ;   ("julia-testimages" ,julia-testimages)))
> > +    ; (list julia-aqua
> > +    ;       julia-documenter
> > +    ;       julia-imagefiltering
> > +    ;       julia-imageio
> > +    ;       julia-imagemagick
> > +    ;       julia-offsetarrays
> > +    ;       jula-statistics
> > +    ;       julia-testimages))
> 
> Is this change useful?  Is it for maintaining an accurate list for
> passing tests if we cut the cycle?

Its an updated list of the packages we would need for the tests to run.
I'd rather have them listed (and up to date) than missing and have to
start searching before finding out how much effort it'll be to cut the
cycle. On its own it's not a useful change, but with the actual package
upgrade it seemed like a good change to make.
diff mbox series

Patch

diff --git a/gnu/packages/julia-xyz.scm b/gnu/packages/julia-xyz.scm
index 130df81ae2..599940f0c7 100644
--- a/gnu/packages/julia-xyz.scm
+++ b/gnu/packages/julia-xyz.scm
@@ -2552,7 +2552,7 @@  (define-public julia-imageaxes
 (define-public julia-imagebase
   (package
     (name "julia-imagebase")
-    (version "0.1.1")
+    (version "0.1.5")
     (source
       (origin
         (method git-fetch)
@@ -2561,7 +2561,7 @@  (define-public julia-imagebase
                (commit (string-append "v" version))))
         (file-name (git-file-name name version))
         (sha256
-         (base32 "1n63f2zs6ail9pcl7rzgv3l0z8v1idjsaza3zgvgy7iacxsdpcj2"))))
+         (base32 "00gi268jsyhlkadkkbyiffph6c8yb7zw34px76n6hs7dkfzp6jm3"))))
     (build-system julia-build-system)
     (arguments
      (list #:tests? #f))    ; Cycle with ImageMagick.jl.
@@ -2569,9 +2569,14 @@  (define-public julia-imagebase
      (list julia-imagecore
            julia-reexport))
     ;(native-inputs
-    ; `(("julia-imagemagick" ,julia-imagemagick)
-    ;   ("julia-offsetarrays" ,julia-offsetarrays)
-    ;   ("julia-testimages" ,julia-testimages)))
+    ; (list julia-aqua
+    ;       julia-documenter
+    ;       julia-imagefiltering
+    ;       julia-imageio
+    ;       julia-imagemagick
+    ;       julia-offsetarrays
+    ;       jula-statistics
+    ;       julia-testimages))
     (home-page "https://github.com/JuliaImages/ImageBase.jl")
     (synopsis "Wrapper package around ImageCore")
     (description "This is a twin package to @code{ImageCore} with functions that