diff mbox series

[bug#60075,47/58] gnu: julia-scanbyte: Limit to x86_64-linux.

Message ID b61d09256b5fe86223f8f91bf563c13846f62aa7.1671049574.git.efraim@flashner.co.il
State New
Headers show
Series New julia patches | expand

Commit Message

Efraim Flashner Dec. 14, 2022, 8:35 p.m. UTC
* gnu/packages/julia-xyz.scm (julia-scanbyte)[supported-systems]: New
field.
---
 gnu/packages/julia-xyz.scm | 2 ++
 1 file changed, 2 insertions(+)

Comments

Simon Tournier Dec. 19, 2022, 6:47 p.m. UTC | #1
Hi,

On Wed, 14 Dec 2022 at 22:35, Efraim Flashner <efraim@flashner.co.il> wrote:
> * gnu/packages/julia-xyz.scm (julia-scanbyte)[supported-systems]: New
> field.

> +    ;; https://github.com/jakobnissen/ScanByte.jl/issues/2
> +    (supported-systems '("x86_64-linux"))

In patch [1]:

    [PATCH 44/58] gnu: julia-indexablebitvectors: Limit to 64-bit systems.

is introduced, instead, the change:

--8<---------------cut here---------------start------------->8---
+    (supported-systems %64bit-supported-systems)
--8<---------------cut here---------------end--------------->8---

Well, I think it would better to keep consistency.

1: https://issues.guix.gnu.org/msgid/ce3eb363cbd85c064a8a8aebac5e99e1c40edec4.1671049574.git.efraim@flashner.co.il


Cheers,
simon
Efraim Flashner Dec. 21, 2022, 5:10 p.m. UTC | #2
On Mon, Dec 19, 2022 at 07:47:23PM +0100, zimoun wrote:
> Hi,
> 
> On Wed, 14 Dec 2022 at 22:35, Efraim Flashner <efraim@flashner.co.il> wrote:
> > * gnu/packages/julia-xyz.scm (julia-scanbyte)[supported-systems]: New
> > field.
> 
> > +    ;; https://github.com/jakobnissen/ScanByte.jl/issues/2
> > +    (supported-systems '("x86_64-linux"))
> 
> In patch [1]:
> 
>     [PATCH 44/58] gnu: julia-indexablebitvectors: Limit to 64-bit systems.
> 
> is introduced, instead, the change:
> 
> --8<---------------cut here---------------start------------->8---
> +    (supported-systems %64bit-supported-systems)
> --8<---------------cut here---------------end--------------->8---
> 
> Well, I think it would better to keep consistency.
> 
> 1: https://issues.guix.gnu.org/msgid/ce3eb363cbd85c064a8a8aebac5e99e1c40edec4.1671049574.git.efraim@flashner.co.il

scanbyte relies on architecture specific implementations of functions
and hasn't been ported to other architectures yet. I actually started
looking into it before I realized it was something I could save for
later.
diff mbox series

Patch

diff --git a/gnu/packages/julia-xyz.scm b/gnu/packages/julia-xyz.scm
index 82f71b298b..0dd075a959 100644
--- a/gnu/packages/julia-xyz.scm
+++ b/gnu/packages/julia-xyz.scm
@@ -5046,6 +5046,8 @@  (define-public julia-scanbyte
     (description "This package finds the first occurrence of a byte or set of
 bytes in a chunk of memory.  Think of it like a much faster version of
 @code{findfirst} that only iterates over bytes in memory.")
+    ;; https://github.com/jakobnissen/ScanByte.jl/issues/2
+    (supported-systems '("x86_64-linux"))
     (license license:expat)))
 
 (define-public julia-scratch