diff mbox series

[bug#55005,09/13] gnu: Add ghc-monoid-subclasses

Message ID 20220418180957.19545-9-thomas@thomaslabs.org
State New
Headers show
Series gnu: Add multiple haskell packages | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch success View Laminar job
cbaines/issue success View issue

Commit Message

Thomas Albers Raviola April 18, 2022, 6:09 p.m. UTC
---
 gnu/packages/haskell-xyz.scm | 26 ++++++++++++++++++++++++++
 1 file changed, 26 insertions(+)
diff mbox series

Patch

diff --git a/gnu/packages/haskell-xyz.scm b/gnu/packages/haskell-xyz.scm
index 657eb496a5..fdc9edabde 100644
--- a/gnu/packages/haskell-xyz.scm
+++ b/gnu/packages/haskell-xyz.scm
@@ -16296,3 +16296,29 @@  (define-public ghc-record-dot-preprocessor
      "Preprocessor to allow the @code{record.field} syntax to access the
 fields of records in Haskell.")
     (license license:bsd-3)))
+
+(define-public ghc-monoid-subclasses
+  (package
+    (name "ghc-monoid-subclasses")
+    (version "1.1.3")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (hackage-uri "monoid-subclasses" version))
+       (sha256
+        (base32 "1nglki10rlpi872p55pa8g809q5sna7yzh3zw4rqfhq89kb15wcv"))))
+    (build-system haskell-build-system)
+    (outputs '("out" "static"))
+    (inputs (list ghc-primes ghc-vector))
+    (native-inputs
+     (list ghc-quickcheck
+           ghc-quickcheck-instances
+           ghc-tasty
+           ghc-tasty-quickcheck))
+    (home-page "https://github.com/blamario/monoid-subclasses/")
+    (synopsis "Subclasses of Monoid")
+    (description
+     "This package provides a hierarchy of subclasses of @code{Monoid}
+together with their instances for all data structures from base, containers,
+and text packages.")
+    (license license:bsd-3)))