diff mbox series

[bug#55005,12/13] gnu: Add ghc-deque

Message ID 20220418180957.19545-12-thomas@thomaslabs.org
State New
Headers show
Series gnu: Add multiple haskell packages | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch success View Laminar job
cbaines/issue success View issue

Commit Message

Thomas Albers Raviola April 18, 2022, 6:09 p.m. UTC
---
 gnu/packages/haskell-xyz.scm | 27 +++++++++++++++++++++++++++
 1 file changed, 27 insertions(+)
diff mbox series

Patch

diff --git a/gnu/packages/haskell-xyz.scm b/gnu/packages/haskell-xyz.scm
index cd6de908c6..2b8ea5c8e8 100644
--- a/gnu/packages/haskell-xyz.scm
+++ b/gnu/packages/haskell-xyz.scm
@@ -16369,3 +16369,30 @@  (define-public ghc-strict-list
     (description
      "Implementation of strict linked list with care taken about stack.")
     (license license:expat)))
+
+(define-public ghc-deque
+  (package
+    (name "ghc-deque")
+    (version "0.4.4")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (hackage-uri "deque" version))
+       (sha256
+        (base32 "1x0rjdqgf4kwgpyisx618waz6r9gki3ivav9m4biysyc04hdhinn"))))
+    (build-system haskell-build-system)
+    (outputs '("out" "static"))
+    (inputs (list ghc-hashable ghc-strict-list))
+    (native-inputs
+     (list ghc-quickcheck
+           ghc-quickcheck-instances
+           ghc-rerebase
+           ghc-tasty
+           ghc-tasty-hunit
+           ghc-tasty-quickcheck))
+    (home-page "https://github.com/nikita-volkov/deque")
+    (synopsis "Double-ended queues")
+    (description
+     "Strict and lazy implementations of Double-Ended Queue based on head-tail
+linked list.")
+    (license license:expat)))