diff mbox series

[bug#55005,05/13] gnu: Add ghc-optparse-simple

Message ID 20220418180957.19545-5-thomas@thomaslabs.org
State New
Headers show
Series gnu: Add multiple haskell packages | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch success View Laminar job
cbaines/issue success View issue

Commit Message

Thomas Albers Raviola April 18, 2022, 6:09 p.m. UTC
---
 gnu/packages/haskell-xyz.scm | 22 ++++++++++++++++++++++
 1 file changed, 22 insertions(+)

Comments

M April 18, 2022, 6:30 p.m. UTC | #1
Thomas Albers via Guix-patches via schreef op ma 18-04-2022 om 20:09
[+0200]:
> +    (synopsis "Simple interface to @code{ghc-optparse-applicative}")
> +    (description
> +     "Simple helper functions to work with @code{ghc-optparse-applicative}.")

The synopsis and description is virtually identical, and this doesn't
explain what ghc-optparse-simple is useful for.

More generally, upstream synopses and descriptions are rather limited
and need to be expanded and rewritten a bit.  ‘Synopses and
Descriptions’ in the manual has some tips.

Greetings,
Maxime.
diff mbox series

Patch

diff --git a/gnu/packages/haskell-xyz.scm b/gnu/packages/haskell-xyz.scm
index 314209f573..b9b2824dc4 100644
--- a/gnu/packages/haskell-xyz.scm
+++ b/gnu/packages/haskell-xyz.scm
@@ -16204,3 +16204,25 @@  (define-public ghc-githash
      "Template Haskell splices for including the current git hash and branch
 in the code of a project.")
     (license license:bsd-3)))
+
+(define-public ghc-optparse-simple
+  (package
+    (name "ghc-optparse-simple")
+    (version "0.1.1.4")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (string-append
+             "https://hackage.haskell.org/package/optparse-simple/optparse-simple-"
+             version
+             ".tar.gz"))
+       (sha256
+        (base32 "0y3qgab8csiwyv60cnpzpv65n3c0ikvdx5b5mfkfahkv8xfdh08x"))))
+    (build-system haskell-build-system)
+    (outputs '("out" "static"))
+    (inputs (list ghc-githash ghc-optparse-applicative ghc-th-compat))
+    (home-page "https://github.com/fpco/optparse-simple")
+    (synopsis "Simple interface to @code{ghc-optparse-applicative}")
+    (description
+     "Simple helper functions to work with @code{ghc-optparse-applicative}.")
+    (license license:bsd-3)))