diff mbox series

[bug#55005,03/13] gnu: Add ghc-sqlite-simple

Message ID 20220418180957.19545-3-thomas@thomaslabs.org
State New
Headers show
Series gnu: Add multiple haskell packages | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch success View Laminar job
cbaines/issue success View issue

Commit Message

Thomas Albers Raviola April 18, 2022, 6:09 p.m. UTC
---
 gnu/packages/haskell-xyz.scm | 29 +++++++++++++++++++++++++++++
 1 file changed, 29 insertions(+)
diff mbox series

Patch

diff --git a/gnu/packages/haskell-xyz.scm b/gnu/packages/haskell-xyz.scm
index a1f4678730..18baf7b2f8 100644
--- a/gnu/packages/haskell-xyz.scm
+++ b/gnu/packages/haskell-xyz.scm
@@ -16150,3 +16150,32 @@  (define-public ghc-direct-sqlite
      "Low-level binding to SQLite3.  It supports strings encoded as UTF8, and
 BLOBs represented as ByteStrings.")
     (license license:bsd-3)))
+
+(define-public ghc-sqlite-simple
+  (package
+    (name "ghc-sqlite-simple")
+    (version "0.4.18.0")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (string-append
+             "https://hackage.haskell.org/package/sqlite-simple/sqlite-simple-"
+             version
+             ".tar.gz"))
+       (sha256
+        (base32 "00icsf8pgrcqcn5562lmn12yz1f16a2v2q6bl90iknvjyrk1hgzp"))))
+    (build-system haskell-build-system)
+    (outputs '("out" "static"))
+    (inputs
+     (list ghc-attoparsec
+           ghc-blaze-builder
+           ghc-blaze-textual
+           ghc-direct-sqlite
+           ghc-semigroups
+           ghc-only))
+    (native-inputs (list ghc-base16-bytestring ghc-hunit))
+    (home-page "https://github.com/nurpax/sqlite-simple")
+    (synopsis "Mid-Level SQLite client library")
+    (description
+     "Mid-level SQLite client library, based on postgresql-simple.")
+    (license license:bsd-3)))