diff mbox series

[bug#55005,08/13] gnu: Add ghc-record-dot-preprocessor

Message ID 20220418180957.19545-8-thomas@thomaslabs.org
State New
Headers show
Series gnu: Add multiple haskell packages | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch success View Laminar job
cbaines/issue success View issue

Commit Message

Thomas Albers Raviola April 18, 2022, 6:09 p.m. UTC
---
 gnu/packages/haskell-xyz.scm | 21 +++++++++++++++++++++
 1 file changed, 21 insertions(+)
diff mbox series

Patch

diff --git a/gnu/packages/haskell-xyz.scm b/gnu/packages/haskell-xyz.scm
index 4d50437ed4..657eb496a5 100644
--- a/gnu/packages/haskell-xyz.scm
+++ b/gnu/packages/haskell-xyz.scm
@@ -16275,3 +16275,24 @@  (define-public ghc-record-hasfield
 after the implementation of GHC proposal #42, plus some helper functions over
 it.")
     (license license:bsd-3)))
+
+(define-public ghc-record-dot-preprocessor
+  (package
+    (name "ghc-record-dot-preprocessor")
+    (version "0.2.14")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (hackage-uri "record-dot-preprocessor" version))
+       (sha256
+        (base32 "07hq90pk30p14jqk016wchmqrc1qhwa9qajaj90i363g3arcb24p"))))
+    (build-system haskell-build-system)
+    (outputs '("out" "static"))
+    (inputs (list ghc-uniplate ghc-extra))
+    (native-inputs (list ghc-record-hasfield))
+    (home-page "https://github.com/ndmitchell/record-dot-preprocessor")
+    (synopsis "Preprocessor to allow @code{record.field} syntax")
+    (description
+     "Preprocessor to allow the @code{record.field} syntax to access the
+fields of records in Haskell.")
+    (license license:bsd-3)))