diff mbox series

[bug#55005,07/13] gnu: Add ghc-record-hasfield

Message ID 20220418180957.19545-7-thomas@thomaslabs.org
State New
Headers show
Series gnu: Add multiple haskell packages | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch success View Laminar job
cbaines/issue success View issue

Commit Message

Thomas Albers Raviola April 18, 2022, 6:09 p.m. UTC
---
 gnu/packages/haskell-xyz.scm | 23 +++++++++++++++++++++++
 1 file changed, 23 insertions(+)
diff mbox series

Patch

diff --git a/gnu/packages/haskell-xyz.scm b/gnu/packages/haskell-xyz.scm
index 5352e9f0b6..4d50437ed4 100644
--- a/gnu/packages/haskell-xyz.scm
+++ b/gnu/packages/haskell-xyz.scm
@@ -16252,3 +16252,26 @@  (define-public ghc-algebraic-graphs
      "Library for algebraic construction and manipulation of graphs in
 Haskell.")
     (license license:expat)))
+
+(define-public ghc-record-hasfield
+  (package
+    (name "ghc-record-hasfield")
+    (version "1.0")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (string-append
+             "https://hackage.haskell.org/package/record-hasfield/record-hasfield-"
+             version
+             ".tar.gz"))
+       (sha256
+        (base32 "1jlyhj4nlj4hrypdcv7393nccjmfjnh1311incgqhm5wzigjygaj"))))
+    (build-system haskell-build-system)
+    (outputs '("out" "static"))
+    (home-page "https://github.com/ndmitchell/record-hasfield")
+    (synopsis "Implementation of @code{GHC.Records}")
+    (description
+     "This package provides a version of @code{GHC.Records} as it will be
+after the implementation of GHC proposal #42, plus some helper functions over
+it.")
+    (license license:bsd-3)))