diff mbox series

[bug#55005,13/13] gnu: Add ghc-mod

Message ID 20220418180957.19545-13-thomas@thomaslabs.org
State New
Headers show
Series gnu: Add multiple haskell packages | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch success View Laminar job
cbaines/issue success View issue

Commit Message

Thomas Albers Raviola April 18, 2022, 6:09 p.m. UTC
---
 gnu/packages/haskell-xyz.scm | 26 ++++++++++++++++++++++++++
 1 file changed, 26 insertions(+)
diff mbox series

Patch

diff --git a/gnu/packages/haskell-xyz.scm b/gnu/packages/haskell-xyz.scm
index 2b8ea5c8e8..9c378f795f 100644
--- a/gnu/packages/haskell-xyz.scm
+++ b/gnu/packages/haskell-xyz.scm
@@ -16396,3 +16396,29 @@  (define-public ghc-deque
      "Strict and lazy implementations of Double-Ended Queue based on head-tail
 linked list.")
     (license license:expat)))
+
+(define-public ghc-mod
+  (package
+    (name "ghc-mod")
+    (version "0.1.2.2")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (hackage-uri "mod" version))
+       (sha256
+        (base32 "0m92yd323kjjwnphqlima2aj0hh7i1gnpblc8a29ks25gj0sv66v"))))
+    (build-system haskell-build-system)
+    (outputs '("out" "static"))
+    (inputs (list ghc-semirings ghc-primitive ghc-vector))
+    (native-inputs
+     (list ghc-quickcheck-classes-base
+           ghc-tasty
+           ghc-tasty-quickcheck
+           ghc-quickcheck-classes
+           ghc-quickcheck-classes))
+    (home-page "https://github.com/Bodigrim/mod")
+    (synopsis "Type-safe modular arithmetic")
+    (description
+     "Modular arithmetic, promoting moduli to the type level, with an emphasis
+on performance.  Originally part of @code{arithmoi} package.")
+    (license license:expat)))