diff mbox series

[bug#55005,06/13] gnu: Add ghc-algebraic-graphs

Message ID 20220418180957.19545-6-thomas@thomaslabs.org
State New
Headers show
Series gnu: Add multiple haskell packages | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch success View Laminar job
cbaines/issue success View issue

Commit Message

Thomas Albers Raviola April 18, 2022, 6:09 p.m. UTC
---
 gnu/packages/haskell-xyz.scm | 26 ++++++++++++++++++++++++++
 1 file changed, 26 insertions(+)
diff mbox series

Patch

diff --git a/gnu/packages/haskell-xyz.scm b/gnu/packages/haskell-xyz.scm
index b9b2824dc4..5352e9f0b6 100644
--- a/gnu/packages/haskell-xyz.scm
+++ b/gnu/packages/haskell-xyz.scm
@@ -16226,3 +16226,29 @@  (define-public ghc-optparse-simple
     (description
      "Simple helper functions to work with @code{ghc-optparse-applicative}.")
     (license license:bsd-3)))
+
+(define-public ghc-algebraic-graphs
+  (package
+    (name "ghc-algebraic-graphs")
+    (version "0.6")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (string-append
+             "https://hackage.haskell.org/package/algebraic-graphs/algebraic-graphs-"
+             version
+             ".tar.gz"))
+       (sha256
+        (base32 "1d3gwyimrzcc7i2qj3iimab3wz6vicgwybhq7ac3da86b8pjlgim"))))
+    (build-system haskell-build-system)
+        (outputs '("out" "static"))
+    (native-inputs (list ghc-extra ghc-inspection-testing ghc-quickcheck))
+    (arguments
+     `(#:cabal-revision
+       ("1" "0f7ih4d0jls7399slxc3zkg38z32jm80jv74iyy42l8s6m5ya1cv")))
+    (home-page "https://github.com/snowleopard/alga")
+    (synopsis "Library for algebraic graph construction and transformation")
+    (description
+     "Library for algebraic construction and manipulation of graphs in
+Haskell.")
+    (license license:expat)))