[bug#68023,04/13] gnu: Add rust-triomphe-0.1.
Commit Message
* gnu/packages/crates-io.scm (rust-triomphe-0.1): New variable.
Signed-off-by: Mathieu Othacehe <othacehe@gnu.org>
Change-Id: I4bd9ea34b30ae03f8f8dbc4a083d6e246c746ee5
---
gnu/packages/crates-io.scm | 25 +++++++++++++++++++++++++
1 file changed, 25 insertions(+)
Comments
On Mon, Dec 25, 2023 at 10:09:20AM +0100, Mathieu Othacehe wrote:
> * gnu/packages/crates-io.scm (rust-triomphe-0.1): New variable.
>
> Signed-off-by: Mathieu Othacehe <othacehe@gnu.org>
> Change-Id: I4bd9ea34b30ae03f8f8dbc4a083d6e246c746ee5
> ---
> gnu/packages/crates-io.scm | 25 +++++++++++++++++++++++++
> 1 file changed, 25 insertions(+)
>
> diff --git a/gnu/packages/crates-io.scm b/gnu/packages/crates-io.scm
> index b552fbb1c3..18b26f4c50 100644
> --- a/gnu/packages/crates-io.scm
> +++ b/gnu/packages/crates-io.scm
> @@ -82710,6 +82710,31 @@ (define-public rust-treeline-0.1
> "This package provides a library for visualizing tree structured data.")
> (license license:expat)))
>
> +(define-public rust-triomphe-0.1
> + (package
> + (name "rust-triomphe")
> + (version "0.1.11")
> + (source
> + (origin
> + (method url-fetch)
> + (uri (crate-uri "triomphe" version))
> + (file-name (string-append name "-" version ".tar.gz"))
> + (sha256
> + (base32 "1crf71hndy3fc68x8v4aikkdjynp4n5sdhq28sck8x7frx8bd7l5"))))
> + (build-system cargo-build-system)
> + (arguments
> + `(#:cargo-inputs (("rust-arc-swap" ,rust-arc-swap-1)
> + ("rust-serde" ,rust-serde-1)
> + ("rust-stable-deref-trait" ,rust-stable-deref-trait-1)
> + ("rust-unsize" ,rust-unsize-1))))
> + (home-page "https://github.com/Manishearth/triomphe")
> + (synopsis
> + "Fork of std::sync::Arc with some extra functionality")
> + (description
> + "This package provides a fork of std::sync::Arc with some extra
std::sync::Arc can be wrapped in @code
> +functionality and without weak references (originally servo_arc).")
> + (license (list license:expat license:asl2.0))))
> +
> (define-public rust-triple-accel-0.4
> (package
> (name "rust-triple-accel")
> --
> 2.41.0
>
@@ -82710,6 +82710,31 @@ (define-public rust-treeline-0.1
"This package provides a library for visualizing tree structured data.")
(license license:expat)))
+(define-public rust-triomphe-0.1
+ (package
+ (name "rust-triomphe")
+ (version "0.1.11")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (crate-uri "triomphe" version))
+ (file-name (string-append name "-" version ".tar.gz"))
+ (sha256
+ (base32 "1crf71hndy3fc68x8v4aikkdjynp4n5sdhq28sck8x7frx8bd7l5"))))
+ (build-system cargo-build-system)
+ (arguments
+ `(#:cargo-inputs (("rust-arc-swap" ,rust-arc-swap-1)
+ ("rust-serde" ,rust-serde-1)
+ ("rust-stable-deref-trait" ,rust-stable-deref-trait-1)
+ ("rust-unsize" ,rust-unsize-1))))
+ (home-page "https://github.com/Manishearth/triomphe")
+ (synopsis
+ "Fork of std::sync::Arc with some extra functionality")
+ (description
+ "This package provides a fork of std::sync::Arc with some extra
+functionality and without weak references (originally servo_arc).")
+ (license (list license:expat license:asl2.0))))
+
(define-public rust-triple-accel-0.4
(package
(name "rust-triple-accel")