@@ -4949,15 +4949,13 @@ (define-public python-ddlparse
(define-public python-jsonschema
(package
(name "python-jsonschema")
- ;; XXX: Update to the latest version requires new build system - Hatch
- ;; https://hatch.pypa.io/
- (version "4.5.1")
+ (version "4.17.3")
(source
(origin
(method url-fetch)
(uri (pypi-uri "jsonschema" version))
(sha256
- (base32 "1z0x22691jva7lwfcfh377jdmlz68zhiawxzl53k631l34k8hvbw"))))
+ (base32 "03dnxhvzfxmnpn53zsc0598hsslaz7w3wi87cyx7cq4bmcvl91hg"))))
(build-system pyproject-build-system)
(arguments
(list
@@ -4968,17 +4966,21 @@ (define-public python-jsonschema
;; without the git metadata available, the version string is set to
;; '0.0.0'.
(lambda _
- (setenv "SETUPTOOLS_SCM_PRETEND_VERSION" #$version)))
- (replace 'check
- (lambda* (#:key tests? #:allow-other-keys)
- (when tests?
- (setenv "JSON_SCHEMA_TEST_SUITE" "json")
- (invoke "trial" "jsonschema")))))))
- (native-inputs (list python-setuptools-scm python-twisted))
+ (setenv "SETUPTOOLS_SCM_PRETEND_VERSION" #$version))))))
+ (native-inputs (list python-hatchling
+ python-hatch-fancy-pypi-readme
+ python-hatch-vcs
+ python-jsonschema-specifications
+ python-pytest
+ python-setuptools-scm
+ python-trove-classifiers
+ python-twisted))
(propagated-inputs
(list python-attrs
python-importlib-metadata
python-pyrsistent
+ python-referencing
+ python-rpds-py
python-typing-extensions))
(home-page "https://github.com/Julian/jsonschema")
(synopsis "Implementation of JSON Schema for Python")
* gnu/packages/python-xyz.scm (python-jsonschema): Update to 4.17.3. [arguments]: Do not replace the 'check phase. [native-inputs]: Add python-hatchling, python-hatch-fancy-pypi-readme, python-hatch-vcs, python-jsonschema-specifications, python-pytest, python-rpds-py, python-trove-classifiers. [propagated-inputs]: Add python-referencing, python-rpds-py. Change-Id: I39e5128d851470d25ef31edf3baefcdf6d690fa6 Signed-off-by: Mathieu Othacehe <othacehe@gnu.org> --- gnu/packages/python-xyz.scm | 24 +++++++++++++----------- 1 file changed, 13 insertions(+), 11 deletions(-)