@@ -85437,6 +85437,26 @@ (define-public rust-unsafe-unwrap-0.1
"This crate enables unchecked unwrapping on Option and Result types.")
(license (list license:expat license:asl2.0))))
+(define-public rust-unsize-1
+ (package
+ (name "rust-unsize")
+ (version "1.1.0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (crate-uri "unsize" version))
+ (file-name (string-append name "-" version ".tar.gz"))
+ (sha256
+ (base32 "0fd9lzdhkahygxy9b348m0fs4wlldh5ymp1dcr56d9f16jksg9sg"))))
+ (build-system cargo-build-system)
+ (arguments
+ `(#:cargo-inputs (("rust-autocfg" ,rust-autocfg-1))))
+ (home-page "https://github.com/HeroicKatora/static-alloc")
+ (synopsis "Stable alternative to CoerceUnsize")
+ (description
+ "This package provides a stable alternative to @code{CoerceUnsize}.")
+ (license (list license:expat license:asl2.0 license:zlib))))
+
(define-public rust-untrusted-0.7
(package
(name "rust-untrusted")
* gnu/packages/crates-io.scm (rust-unsize-1): New variable. Signed-off-by: Mathieu Othacehe <othacehe@gnu.org> Change-Id: Iae3dcb97809622e79ae6dc74ed94723ff1da8e29 --- gnu/packages/crates-io.scm | 20 ++++++++++++++++++++ 1 file changed, 20 insertions(+)