@@ -5038,6 +5038,32 @@ (define-public python-schema-0.5
(base32
"10zqvpaky51kgb8nd42bk7jwl8cn2zvayxjpdc1wwmpybj92x67s"))))))
+(define-public python-jsonschema-specifications
+ (package
+ (name "python-jsonschema-specifications")
+ (version "2023.11.2")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (pypi-uri "jsonschema_specifications" version))
+ (sha256
+ (base32 "1f41kby85dd1yzy0xa1fvgjakdfcmq6ijasax95xfk27x97zqwll"))))
+ (build-system pyproject-build-system)
+ (native-inputs
+ (list python-hatchling
+ python-hatch-fancy-pypi-readme
+ python-hatch-vcs
+ python-pytest))
+ (propagated-inputs
+ (list python-importlib-resources python-referencing))
+ (home-page "https://github.com/python-jsonschema/jsonschema-specifications")
+ (synopsis "JSON Schema Specifications support")
+ (description
+ "This package provides support for the JSON Schema
+Specifications (metaschemas, vocabularies, ...), packaged for runtime access
+from Python as a referencing-based Schema Registry.")
+ (license license:expat)))
+
(define-public python-kitchen
(package
(name "python-kitchen")
* gnu/packages/python-xyz.scm (python-jsonschema-specifications): New variable. Signed-off-by: Mathieu Othacehe <othacehe@gnu.org> Change-Id: I967800d6867d6a6405230aa48ed4a06ee3d42d14 --- gnu/packages/python-xyz.scm | 26 ++++++++++++++++++++++++++ 1 file changed, 26 insertions(+)