[bug#68023,05/13] gnu: Add rust-compiletest-rs-0.10.
Commit Message
* gnu/packages/crates-io.scm (rust-compiletest-rs-0.10): New variable.
Signed-off-by: Mathieu Othacehe <othacehe@gnu.org>
Change-Id: Ibd6fc9fa1803df3a804801a10923b8b70c1f4073
---
gnu/packages/crates-io.scm | 37 +++++++++++++++++++++++++++++++++++++
1 file changed, 37 insertions(+)
Comments
Please have rust-compiletest-rs-0.3 inherit from this package. I
normally compare the home-page, synopsis and description between the two
and choose the "better" one for the added package.
On Mon, Dec 25, 2023 at 10:09:21AM +0100, Mathieu Othacehe wrote:
> * gnu/packages/crates-io.scm (rust-compiletest-rs-0.10): New variable.
>
> Signed-off-by: Mathieu Othacehe <othacehe@gnu.org>
> Change-Id: Ibd6fc9fa1803df3a804801a10923b8b70c1f4073
> ---
> gnu/packages/crates-io.scm | 37 +++++++++++++++++++++++++++++++++++++
> 1 file changed, 37 insertions(+)
>
> diff --git a/gnu/packages/crates-io.scm b/gnu/packages/crates-io.scm
> index 18b26f4c50..b09fbbd05f 100644
> --- a/gnu/packages/crates-io.scm
> +++ b/gnu/packages/crates-io.scm
> @@ -14949,6 +14949,43 @@ (define-public rust-compiler-error-0.1
> (description "This package provides a triggerable compiler error for Rust.")
> (license license:expat)))
>
> +(define-public rust-compiletest-rs-0.10
> + (package
> + (name "rust-compiletest-rs")
> + (version "0.10.2")
> + (source
> + (origin
> + (method url-fetch)
> + (uri (crate-uri "compiletest_rs" version))
> + (file-name (string-append name "-" version ".tar.gz"))
> + (sha256
> + (base32 "1mn0v8qax92pl9kdf2csah79jyigzvndg8mil6rpn97rpkhzw9bj"))))
> + (build-system cargo-build-system)
> + (arguments
> + `(#:cargo-inputs
> + (("rust-diff" ,rust-diff-0.1)
> + ("rust-filetime" ,rust-filetime-0.2)
> + ("rust-getopts" ,rust-getopts-0.2)
> + ("rust-lazy-static" ,rust-lazy-static-1)
> + ("rust-libc" ,rust-libc-0.2)
> + ("rust-log" ,rust-log-0.4)
> + ("rust-miow" ,rust-miow-0.3)
> + ("rust-regex" ,rust-regex-1)
> + ("rust-rustfix" ,rust-rustfix-0.6)
> + ("rust-serde" ,rust-serde-1)
> + ("rust-serde-derive" ,rust-serde-derive-1)
> + ("rust-serde-json" ,rust-serde-json-1)
> + ("rust-tempfile" ,rust-tempfile-3)
> + ("rust-tester" ,rust-tester-0.9)
> + ("rust-winapi" ,rust-winapi-0.3))))
> + (home-page "https://github.com/Manishearth/compiletest-rs")
> + (synopsis
> + "Extraction of the compiletest utility from the Rust compiler")
> + (description
> + "This package provides an extraction of the compiletest utility from the
> +Rust compiler.")
> + (license (list license:asl2.0 license:expat))))
> +
> (define-public rust-compiletest-rs-0.3
> (package
> (name "rust-compiletest-rs")
> --
> 2.41.0
>
@@ -14949,6 +14949,43 @@ (define-public rust-compiler-error-0.1
(description "This package provides a triggerable compiler error for Rust.")
(license license:expat)))
+(define-public rust-compiletest-rs-0.10
+ (package
+ (name "rust-compiletest-rs")
+ (version "0.10.2")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (crate-uri "compiletest_rs" version))
+ (file-name (string-append name "-" version ".tar.gz"))
+ (sha256
+ (base32 "1mn0v8qax92pl9kdf2csah79jyigzvndg8mil6rpn97rpkhzw9bj"))))
+ (build-system cargo-build-system)
+ (arguments
+ `(#:cargo-inputs
+ (("rust-diff" ,rust-diff-0.1)
+ ("rust-filetime" ,rust-filetime-0.2)
+ ("rust-getopts" ,rust-getopts-0.2)
+ ("rust-lazy-static" ,rust-lazy-static-1)
+ ("rust-libc" ,rust-libc-0.2)
+ ("rust-log" ,rust-log-0.4)
+ ("rust-miow" ,rust-miow-0.3)
+ ("rust-regex" ,rust-regex-1)
+ ("rust-rustfix" ,rust-rustfix-0.6)
+ ("rust-serde" ,rust-serde-1)
+ ("rust-serde-derive" ,rust-serde-derive-1)
+ ("rust-serde-json" ,rust-serde-json-1)
+ ("rust-tempfile" ,rust-tempfile-3)
+ ("rust-tester" ,rust-tester-0.9)
+ ("rust-winapi" ,rust-winapi-0.3))))
+ (home-page "https://github.com/Manishearth/compiletest-rs")
+ (synopsis
+ "Extraction of the compiletest utility from the Rust compiler")
+ (description
+ "This package provides an extraction of the compiletest utility from the
+Rust compiler.")
+ (license (list license:asl2.0 license:expat))))
+
(define-public rust-compiletest-rs-0.3
(package
(name "rust-compiletest-rs")