diff mbox series

[bug#68023,09/13] gnu: Add python-referencing.

Message ID b8d8083c35897ce1b5aa6a5549296318b849e089.1703494195.git.othacehe@gnu.org
State New
Headers show
Series Add support for Linux `make dtbs_check` | expand

Commit Message

Mathieu Othacehe Dec. 25, 2023, 9:09 a.m. UTC
* gnu/packages/python-xyz.scm (python-referencing): New variable.

Signed-off-by: Mathieu Othacehe <othacehe@gnu.org>
Change-Id: I90cfdb3efb0726b445ba35f0336e0a966534d577
---
 gnu/packages/python-xyz.scm | 25 +++++++++++++++++++++++++
 1 file changed, 25 insertions(+)
diff mbox series

Patch

diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 4d3041db2c..e80e3c9089 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -30650,6 +30650,31 @@  (define-public python-reflink
 implementations.")
     (license license:expat)))
 
+(define-public python-referencing
+  (package
+    (name "python-referencing")
+    (version "0.32.0")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (pypi-uri "referencing" version))
+       (sha256
+        (base32 "0qb1zp46ma004wrnflxlzy413ygiiqqk66dpazyxqhqq2bz697k8"))))
+    (build-system pyproject-build-system)
+    (arguments (list #:tests? #f))
+    (native-inputs
+     (list python-hatchling
+           python-hatch-fancy-pypi-readme
+           python-hatch-vcs
+           python-trove-classifiers))
+    (propagated-inputs (list python-attrs python-rpds-py))
+    (home-page "https://github.com/python-jsonschema/referencing")
+    (synopsis "JSON reference resolution")
+    (description "This package provides a way for JSON Schema tooling to
+resolve the @code{$ref} keywords across all drafts without needing to
+implement support themselves.")
+    (license license:expat)))
+
 (define-public python-retry
   (package
     (name "python-retry")