diff mbox series

[bug#68023,13/13] gnu: linux-libre: Add python-dtschema.

Message ID ccad449e822446a00f109a115b4cc293eb089e31.1703494195.git.othacehe@gnu.org
State New
Headers show
Series Add support for Linux `make dtbs_check` | expand

Commit Message

Mathieu Othacehe Dec. 25, 2023, 9:09 a.m. UTC
This allows to run `make dtbs_check` on a Linux checkout after running `guix
shell -D linux-libre`.

* gnu/packages/linux.scm (linux-libre)[native-inputs]: Add python-dtschema.

Signed-off-by: Mathieu Othacehe <othacehe@gnu.org>
Change-Id: I9d67a1efc6ecca4b353ebbebf531fceea1eafd7d
---
 gnu/packages/linux.scm | 4 ++++
 1 file changed, 4 insertions(+)
diff mbox series

Patch

diff --git a/gnu/packages/linux.scm b/gnu/packages/linux.scm
index 2d9e4cebbe..9a9ffc9c13 100644
--- a/gnu/packages/linux.scm
+++ b/gnu/packages/linux.scm
@@ -1077,6 +1077,10 @@  (define* (make-linux-libre* version gnu-revision source supported-systems
            flex
            bison
            util-linux                ;needed for hexdump
+           ;; Needed for dtb validation.
+           (module-ref (resolve-interface
+                        '(gnu packages bootloaders))
+                       'python-dtschema)
            ;; These are needed to compile the GCC plugins.
            gmp
            mpfr