diff mbox series

[bug#62284,07/70] gnu: Add go-google-golang-org-protobuf-proto.

Message ID be66aa7e882e984b7538ec3f30f38658424e4755.1679268195.git.contact@conses.eu
State New
Headers show
Series gnu: Add mautrix-whatsapp. | expand

Commit Message

Miguel Ángel Moreno March 19, 2023, 11:29 p.m. UTC
* gnu/packages/golang.scm (go-google-golang-org-protobuf-proto): New variable.
---
 gnu/packages/golang.scm | 7 +++++++
 1 file changed, 7 insertions(+)
diff mbox series

Patch

diff --git a/gnu/packages/golang.scm b/gnu/packages/golang.scm
index 09ea647602..1de7fc6228 100644
--- a/gnu/packages/golang.scm
+++ b/gnu/packages/golang.scm
@@ -7736,6 +7736,13 @@  (define (go-google-golang-org-protobuf-package suffix)
         (string-append path "/"
                        (string-replace-substring suffix "-" "/")))))))
 
+(define-public go-google-golang-org-protobuf-proto
+  (package (inherit (go-google-golang-org-protobuf-package "proto"))
+    (synopsis "Functions operating on protobuf messages")
+    (description "This package provides functions operating on protobuf
+messages such as cloning, merging, and checking equality, as well as binary
+serialization.")))
+
 (define-public go-github-com-mattn-go-zglob
   (package
     (name "go-github-com-mattn-go-zglob")