diff mbox series

[bug#62284,33/70] gnu: Add go-maunium-net-go-mauflag.

Message ID 12a6d129f993ed3d7a59ee83f14b53a951798956.1679268196.git.contact@conses.eu
State New
Headers show
Series gnu: Add mautrix-whatsapp. | expand

Commit Message

Miguel Ángel Moreno March 19, 2023, 11:40 p.m. UTC
* gnu/packages/golang.scm (go-maunium-net-go-mauflag): New variable.
---
 gnu/packages/golang.scm | 22 ++++++++++++++++++++++
 1 file changed, 22 insertions(+)
diff mbox series

Patch

diff --git a/gnu/packages/golang.scm b/gnu/packages/golang.scm
index 0d4a714dfa..7a8aa9e717 100644
--- a/gnu/packages/golang.scm
+++ b/gnu/packages/golang.scm
@@ -12268,6 +12268,28 @@  (define-public go-github-com-onsi-ginkgo
 Gomega matcher library.")
     (license license:expat)))
 
+(define-public go-maunium-net-go-mauflag
+  (package
+    (name "go-maunium-net-go-mauflag")
+    (version "1.0.0")
+    (source (origin
+              (method git-fetch)
+              (uri (git-reference
+                    (url "https://github.com/tulir/mauflag")
+                    (commit (string-append "v" version))))
+              (file-name (git-file-name name version))
+              (sha256
+               (base32
+                "09jv1819jwq5i29y6ngf4j4ii6qwlshydvprfvsfplc419dkz1vx"))))
+    (build-system go-build-system)
+    (arguments
+     '(#:import-path "maunium.net/go/mauflag"))
+    (home-page "https://github.com/tulir/mauflag")
+    (synopsis "An extendable argument parser for Golang")
+    (description "An extendable argument parser for Golang.  Mostly follows
+the GNU Program Argument Syntax conventions.")
+    (license license:gpl3)))
+
 ;;;
 ;;; Avoid adding new packages to the end of this file. To reduce the chances
 ;;; of a merge conflict, place them above by existing packages with similar