diff mbox series

[bug#62284,63/70] gnu: Add go-github-com-coreos-go-systemd.

Message ID 386a0f1f563b27900e8ad38abfd561fde02f69de.1679268196.git.contact@conses.eu
State New
Headers show
Series gnu: Add mautrix-whatsapp. | expand

Commit Message

Miguel Ángel Moreno March 19, 2023, 11:50 p.m. UTC
* gnu/packages/golang.scm (go-github-com-coreos-go-systemd): New variable.
---
 gnu/packages/golang.scm | 22 ++++++++++++++++++++++
 1 file changed, 22 insertions(+)
diff mbox series

Patch

diff --git a/gnu/packages/golang.scm b/gnu/packages/golang.scm
index bf5843fc75..2e602f1f34 100644
--- a/gnu/packages/golang.scm
+++ b/gnu/packages/golang.scm
@@ -12336,6 +12336,28 @@  (define-public go-github-com-rs-xid
 ready to safely be used directly in your server code.")
     (license license:expat)))
 
+(define-public go-github-com-coreos-go-systemd
+  (package
+    (name "go-github-com-coreos-go-systemd")
+    (version "22.5.0")
+    (source (origin
+              (method git-fetch)
+              (uri (git-reference
+                    (url "https://github.com/coreos/go-systemd")
+                    (commit (string-append "v" version))))
+              (file-name (git-file-name name version))
+              (sha256
+               (base32
+                "1vhb4cw8nw9nx8mprx829xv8w4jnwhc2lcyjljzlfafsn8nx5nyf"))))
+    (build-system go-build-system)
+    (arguments (list #:import-path "github.com/coreos/go-systemd"))
+    (propagated-inputs (list go-github-com-godbus-dbus))
+    (home-page "https://github.com/coreos/go-systemd")
+    (synopsis "Go bindings to systemd")
+    (description "Go bindings to systemd socket activation, journal, D-Bus,
+and unit files.")
+    (license license:asl2.0)))
+
 (define-public go-mau-fi-libsignal
   (package
     (name "go-mau-fi-libsignal")