diff mbox series

[bug#62284,02/70] gnu: Add go-github-com-tidwall-gjson.

Message ID 9697d0cddf9207db6ea9113bfa231067d039e98a.1679268195.git.contact@conses.eu
State New
Headers show
Series gnu: Add mautrix-whatsapp. | expand

Commit Message

Miguel Ángel Moreno March 19, 2023, 11:28 p.m. UTC
* gnu/packages/golang.scm (go-github-com-tidwall-gjson): New variable.
---
 gnu/packages/golang.scm | 26 ++++++++++++++++++++++++++
 1 file changed, 26 insertions(+)
diff mbox series

Patch

diff --git a/gnu/packages/golang.scm b/gnu/packages/golang.scm
index fb4eb628d0..790f61007a 100644
--- a/gnu/packages/golang.scm
+++ b/gnu/packages/golang.scm
@@ -2818,6 +2818,32 @@  (define-public go-github-com-tidwall-sjson
 value in a JSON document.")
     (license license:expat)))
 
+(define-public go-github-com-tidwall-gjson
+  (package
+    (name "go-github-com-tidwall-gjson")
+    (version "1.14.4")
+    (source (origin
+              (method git-fetch)
+              (uri (git-reference
+                    (url "https://github.com/tidwall/gjson")
+                    (commit (string-append "v" version))))
+              (file-name (git-file-name name version))
+              (sha256
+               (base32
+                "1rs8i87j62sgas55cvm8kzcgf40090dq38r6m6s03rzxs9hbcd6w"))))
+    (build-system go-build-system)
+    (arguments
+     '(#:import-path "github.com/tidwall/gjson"))
+    (propagated-inputs
+     (list go-github-com-tidwall-match
+           go-github-com-tidwall-pretty))
+    (home-page "https://github.com/tidwall/gjson")
+    (synopsis "JSON parser for Go")
+    (description "GJSON is a Go package that provides a fast and simple way to
+get values from a JSON document. It has features like one line retrieval, dot
+notation paths, iteration, and parsing JSON lines.")
+    (license license:expat)))
+
 (define-public go-github-com-tj-docopt
   (package
     (name "go-github-com-tj-docopt")