diff mbox series

[bug#62284,03/70] gnu: Add go-github-com-tidwall-match.

Message ID 1f37dee64ccefec59792adf847f222231784d4de.1679268195.git.contact@conses.eu
State New
Headers show
Series gnu: Add mautrix-whatsapp. | expand

Commit Message

Miguel Ángel Moreno March 19, 2023, 11:28 p.m. UTC
* gnu/packages/golang.scm (go-github-com-tidwall-match): New variable.
---
 gnu/packages/golang.scm | 23 +++++++++++++++++++++++
 1 file changed, 23 insertions(+)
diff mbox series

Patch

diff --git a/gnu/packages/golang.scm b/gnu/packages/golang.scm
index 790f61007a..721f4929b5 100644
--- a/gnu/packages/golang.scm
+++ b/gnu/packages/golang.scm
@@ -2844,6 +2844,29 @@  (define-public go-github-com-tidwall-gjson
 notation paths, iteration, and parsing JSON lines.")
     (license license:expat)))
 
+(define-public go-github-com-tidwall-match
+  (package
+    (name "go-github-com-tidwall-match")
+    (version "1.1.1")
+    (source (origin
+              (method git-fetch)
+              (uri (git-reference
+                    (url "https://github.com/tidwall/match")
+                    (commit (string-append "v" version))))
+              (file-name (git-file-name name version))
+              (sha256
+               (base32
+                "1n25md63xr5m66r6zc77n6fgcpv2ljrlk92ivp9hvp8xya22as9k"))))
+    (build-system go-build-system)
+    (arguments
+     '(#:import-path "github.com/tidwall/match"))
+    (home-page "https://github.com/tidwall/match")
+    (synopsis "Simple string pattern matcher for Go")
+    (description "This package is a very simple pattern matcher where @code{*}
+matches on any number of characters and @code{?} matches on any one
+character.")
+    (license license:expat)))
+
 (define-public go-github-com-tj-docopt
   (package
     (name "go-github-com-tj-docopt")