diff mbox series

[bug#62284,34/70] gnu: Add go-maunium-net-go-maulogger.

Message ID 1b990d8f1fb48174cf0f02a3eed71b110a133a0d.1679268196.git.contact@conses.eu
State New
Headers show
Series gnu: Add mautrix-whatsapp. | expand

Commit Message

Miguel Ángel Moreno March 19, 2023, 11:40 p.m. UTC
* gnu/packages/golang.scm (go-maunium-net-go-maulogger): New variable.
---
 gnu/packages/golang.scm | 25 +++++++++++++++++++++++++
 1 file changed, 25 insertions(+)
diff mbox series

Patch

diff --git a/gnu/packages/golang.scm b/gnu/packages/golang.scm
index 7a8aa9e717..56472a9a33 100644
--- a/gnu/packages/golang.scm
+++ b/gnu/packages/golang.scm
@@ -12290,6 +12290,31 @@  (define-public go-maunium-net-go-mauflag
 the GNU Program Argument Syntax conventions.")
     (license license:gpl3)))
 
+(define-public go-maunium-net-go-maulogger
+  (package
+    (name "go-maunium-go-maulogger")
+    (version "2.4.1")
+    (source (origin
+              (method git-fetch)
+              (uri (git-reference
+                    (url "https://github.com/tulir/maulogger")
+                    (commit (string-append "v" version))))
+              (file-name (git-file-name name version))
+              (sha256
+               (base32
+                "07q27ybjpkx86wjhygb186503wb9v1yxj1n5dnkbx2f15q44xjrs"))))
+    (build-system go-build-system)
+    (arguments
+     '(#:import-path "maunium.net/go/maulogger"))
+    (propagated-inputs
+     (list go-github-com-rs-zerolog
+           go-github-com-tidwall-gjson
+           go-github-com-tidwall-sjson))
+    (home-page "https://github.com/tulir/maulogger")
+    (synopsis "A logger for Go programs")
+    (description "A logger in Go.")
+    (license license:mpl2.0)))
+
 ;;;
 ;;; Avoid adding new packages to the end of this file. To reduce the chances
 ;;; of a merge conflict, place them above by existing packages with similar