diff mbox series

[bug#64840,09/12] gnu: Add ghc-hspec-golden.

Message ID 20230724202532.8993-9-distopico@riseup.net
State New
Headers show
Series Add elm-format. | expand

Commit Message

Distopico July 24, 2023, 8:23 p.m. UTC
* gnu/packages/haskell-xyz.scm (ghc-hspec-golden): New variable.
---
 gnu/packages/haskell-xyz.scm | 26 ++++++++++++++++++++++++++
 1 file changed, 26 insertions(+)
diff mbox series

Patch

diff --git a/gnu/packages/haskell-xyz.scm b/gnu/packages/haskell-xyz.scm
index 34a1a32cc7..e3c5d525b1 100644
--- a/gnu/packages/haskell-xyz.scm
+++ b/gnu/packages/haskell-xyz.scm
@@ -16606,6 +16606,32 @@  (define-public ghc-newtype
 such as ala'.")
     (license license:bsd-3)))
 
+(define-public ghc-hspec-golden
+  (package
+    (name "ghc-hspec-golden")
+    (version "0.2.1.0")
+    (source (origin
+              (method url-fetch)
+              (uri (hackage-uri "hspec-golden" version))
+              (sha256
+               (base32
+                "07bfwj10n75l5zskwx4yzi86xxp5b4f692bjjkqs5b970h6gw33y"))))
+    (build-system haskell-build-system)
+    (properties '((upstream-name . "hspec-golden")))
+    (inputs (list ghc-hspec
+                  ghc-hspec-core
+                  ghc-silently
+                  ghc-optparse-applicative
+                  hspec-discover))
+    (home-page "https://hackage.haskell.org/package/hspec-golden")
+    (synopsis "Haskell golden tests for hspec")
+    (description
+     "This package provides golden tests store the expected output in a
+separated file.
+Each time a golden test is executed the output of the subject
+under test (SUT) is compared with the expected output.")
+    (license license:expat)))
+
 (define-public ghc-hspec-hedgehog
   (package
     (name "ghc-hspec-hedgehog")