diff mbox series

[bug#64840,06/12] gnu: Add ghc-text.

Message ID 20230724202532.8993-6-distopico@riseup.net
State New
Headers show
Series Add elm-format. | expand

Commit Message

Distopico July 24, 2023, 8:23 p.m. UTC
* gnu/packages/haskell-xyz.scm (ghc-text): New variable.
---
 gnu/packages/haskell-xyz.scm | 26 ++++++++++++++++++++++++++
 1 file changed, 26 insertions(+)
diff mbox series

Patch

diff --git a/gnu/packages/haskell-xyz.scm b/gnu/packages/haskell-xyz.scm
index 879d662da6..f25fb89950 100644
--- a/gnu/packages/haskell-xyz.scm
+++ b/gnu/packages/haskell-xyz.scm
@@ -12098,6 +12098,32 @@  (define-public ghc-tar-conduit
 interface for extracting and creating tar files.")
     (license license:expat)))
 
+(define-public ghc-text
+  (package
+    (name "ghc-text")
+    (version "2.0.2")
+    (source (origin
+              (method url-fetch)
+              (uri (hackage-uri "text" version))
+              (sha256
+               (base32
+                "1bggb4gq15r7z685w7c7hbm3w4n6day451ickz70d1l919jvwdf7"))))
+    (build-system haskell-build-system)
+    (properties '((upstream-name . "text")))
+    (arguments
+     ;; Disable otherwise crate a circular
+     ;; dependency with tasty
+     (list #:tests? #f))
+    (home-page "https://hackage.haskell.org/package/text")
+    (synopsis "Haskell library for immutable Unicode text type")
+    (description
+     "This package provides a library for immutable Unicode text type
+(both strict and lazy).  The Text type represents Unicode character
+strings, in a time and space-efficient manner.  Also provides text
+processing capabilities that are optimized for performance critical
+use, both in terms of large data quantities and high speed.")
+    (license license:bsd-2)))
+
 (define-public ghc-temporary
   (package
     (name "ghc-temporary")