diff mbox series

[bug#64840,10/12] gnu: Add ghc-bimap.

Message ID 20230724202532.8993-10-distopico@riseup.net
State New
Headers show
Series Add elm-format. | expand

Commit Message

Distopico July 24, 2023, 8:23 p.m. UTC
* gnu/packages/haskell-xyz.scm (ghc-bimap): New variable.
---
 gnu/packages/haskell-xyz.scm | 21 +++++++++++++++++++++
 1 file changed, 21 insertions(+)
diff mbox series

Patch

diff --git a/gnu/packages/haskell-xyz.scm b/gnu/packages/haskell-xyz.scm
index e3c5d525b1..337dcac4d8 100644
--- a/gnu/packages/haskell-xyz.scm
+++ b/gnu/packages/haskell-xyz.scm
@@ -936,6 +936,27 @@  (define-public ghc-bencode
 storing and transmitting loosely structured data.")
     (license license:bsd-3)))
 
+(define-public ghc-bimap
+  (package
+    (name "ghc-bimap")
+    (version "0.5.0")
+    (source (origin
+              (method url-fetch)
+              (uri (hackage-uri "bimap" version))
+              (sha256
+               (base32
+                "158cdwk9jwklcfgbn62dqq255i40w13ifggsdps87sxc5q7lpd5h"))))
+    (build-system haskell-build-system)
+    (properties '((upstream-name . "bimap")))
+    (native-inputs (list ghc-quickcheck))
+    (home-page "https://hackage.haskell.org/package/bimap")
+    (synopsis "Bidirectional mapping between two key types for Haskell")
+    (description
+     "This pckage provides data structure representing a bidirectional
+mapping between two key types.  Each value in the bimap is associated
+with exactly one value of the opposite type.")
+    (license license:bsd-3)))
+
 (define-public ghc-bifunctors
   (package
     (name "ghc-bifunctors")