diff mbox series

[bug#64840,02/12] gnu: Add ghc-generically.

Message ID 20230724202532.8993-2-distopico@riseup.net
State New
Headers show
Series Add elm-format. | expand

Commit Message

Distopico July 24, 2023, 8:23 p.m. UTC
* gnu/packages/haskell-web.scm (ghc-generically): New variable.
---
 gnu/packages/haskell-web.scm | 24 +++++++++++++++++++++++-
 1 file changed, 23 insertions(+), 1 deletion(-)
diff mbox series

Patch

diff --git a/gnu/packages/haskell-web.scm b/gnu/packages/haskell-web.scm
index 75b84b10a7..6c6122299d 100644
--- a/gnu/packages/haskell-web.scm
+++ b/gnu/packages/haskell-web.scm
@@ -13,6 +13,7 @@ 
 ;;; Copyright © 2020 Alexandru-Sergiu Marton <brown121407@member.fsf.org>
 ;;; Copyright © 2020 Giacomo Leidi <goodoldpaul@autistici.org>
 ;;; Copyright © 2022 Alice Brenon <alice.brenon@ens-lyon.fr>
+;;; Copyright © 2023 Camilo Q.S. (Distopico) <distopico@riseup.net>
 ;;;
 ;;; This file is part of GNU Guix.
 ;;;
@@ -1067,6 +1068,28 @@  (define-public ghc-aeson-better-errors
 @url{http://harry.garrood.me/blog/aeson-better-errors/}.")
     (license license:expat)))
 
+(define-public ghc-generically
+  (package
+    (name "ghc-generically")
+    (version "0.1.1")
+    (source (origin
+              (method url-fetch)
+              (uri (hackage-uri "generically" version))
+              (sha256
+               (base32
+                "1ks3pi6mpma83xffplz8vmimyhvzpnhmcgvk3bvl3c64pqva9i84"))))
+    (build-system haskell-build-system)
+    (properties '((upstream-name . "generically")))
+    (arguments
+     `(#:cabal-revision ("1"
+                         "0pkyhym7q9v03pplpfjg80vmpk0cbgc56panfx9vcbzadvxmx6rb")))
+    (home-page "https://hackage.haskell.org/package/generically")
+    (synopsis "Generically newtype to use with DerivingVia in Haskell")
+    (description
+     "This is a compatibility package as @code{Generically} and @code{Generically1}
+newtypes are available since base-4.17 in @code{GHC.Generics}.")
+    (license license:bsd-3)))
+
 (define-public ghc-multipart
   (package
     (name "ghc-multipart")
@@ -2171,4 +2194,3 @@  (define-public ghc-network-run
     (description
      "This package provides a simple network runner library in Haskell.")
     (license license:bsd-3)))
-