diff mbox series

[bug#64840,07/12] gnu: Add ghc-relude.

Message ID 20230724202532.8993-7-distopico@riseup.net
State New
Headers show
Series Add elm-format. | expand

Commit Message

Distopico July 24, 2023, 8:23 p.m. UTC
* gnu/packages/haskell-xyz.scm (ghc-relude): New variable.
---
 gnu/packages/haskell-xyz.scm | 23 +++++++++++++++++++++++
 1 file changed, 23 insertions(+)
diff mbox series

Patch

diff --git a/gnu/packages/haskell-xyz.scm b/gnu/packages/haskell-xyz.scm
index f25fb89950..837c8ade16 100644
--- a/gnu/packages/haskell-xyz.scm
+++ b/gnu/packages/haskell-xyz.scm
@@ -10052,6 +10052,29 @@  (define-public ghc-regex-tdfa
 inspired by libtre.")
     (license license:bsd-3)))
 
+(define-public ghc-relude
+  (package
+    (name "ghc-relude")
+    (version "1.1.0.0")
+    (source (origin
+              (method url-fetch)
+              (uri (hackage-uri "relude" version))
+              (sha256
+               (base32
+                "02dn99v2qmykj0l1qmn15k36hyxccy71b7iqavfk24zgjf5g07dm"))))
+    (build-system haskell-build-system)
+    (properties '((upstream-name . "relude")))
+    (arguments
+     (list #:tests? #f))
+    (native-inputs (list ghc-doctest ghc-glob))
+    (inputs (list ghc-text ghc-hashable ghc-unordered-containers))
+    (home-page "https://hackage.haskell.org/package/relude")
+    (synopsis "Haskell standard library alternative for prelude library")
+    (description
+     "This package provide an haskell standard library alternative for
+the default haskell prelude library.")
+    (license license:expat)))
+
 (define-public ghc-repline
   (package
     (name "ghc-repline")