diff mbox series

[bug#64840,03/12] gnu: Add ghc-aeson-2.1.

Message ID 20230724202532.8993-3-distopico@riseup.net
State New
Headers show
Series Add elm-format. | expand

Commit Message

Distopico July 24, 2023, 8:23 p.m. UTC
* gnu/packages/haskell-web.scm (ghc-aeson-2.1): New variable.
---
 gnu/packages/haskell-web.scm | 16 ++++++++++++++++
 1 file changed, 16 insertions(+)
diff mbox series

Patch

diff --git a/gnu/packages/haskell-web.scm b/gnu/packages/haskell-web.scm
index 6c6122299d..967ff77eec 100644
--- a/gnu/packages/haskell-web.scm
+++ b/gnu/packages/haskell-web.scm
@@ -977,6 +977,22 @@  (define-public ghc-aeson
 naming: in Greek mythology, Aeson was the father of Jason.)")
     (license license:bsd-3)))
 
+(define-public ghc-aeson-2.1
+  (package
+    (inherit ghc-aeson)
+    (version "2.1.2.1")
+    (source (origin
+              (method url-fetch)
+              (uri (hackage-uri "aeson" version))
+              (sha256
+               (base32
+                "1ii26lz9czxqhck11pzhqlhfhm9zgbrhiydv4gh1w66f0fwl4h2x"))))
+    (inputs (modify-inputs (package-inputs ghc-aeson)
+              (prepend ghc-generically)))
+    (arguments
+     `(#:cabal-revision ("1"
+                         "1yiib3ay9961pzs1bb09waw40qkk8w74553bwjp5gkym3dk3q3zi")))))
+
 (define-public ghc-aeson-pretty
   (package
     (name "ghc-aeson-pretty")