diff mbox series

[bug#64840,08/12] gnu: Add ghc-concurrent-split.

Message ID 20230724202532.8993-8-distopico@riseup.net
State New
Headers show
Series Add elm-format. | expand

Commit Message

Distopico July 24, 2023, 8:23 p.m. UTC
* gnu/packages/haskell-xyz.scm (ghc-concurrent-split): New variable.
---
 gnu/packages/haskell-xyz.scm | 20 ++++++++++++++++++++
 1 file changed, 20 insertions(+)
diff mbox series

Patch

diff --git a/gnu/packages/haskell-xyz.scm b/gnu/packages/haskell-xyz.scm
index 837c8ade16..34a1a32cc7 100644
--- a/gnu/packages/haskell-xyz.scm
+++ b/gnu/packages/haskell-xyz.scm
@@ -13345,6 +13345,26 @@  (define-public ghc-unordered-containers-bootstrap
     (native-inputs '())
     (properties '((hidden? #t)))))
 
+(define-public ghc-concurrent-split
+  (package
+    (name "ghc-concurrent-split")
+    (version "0.0.1.1")
+    (source (origin
+              (method url-fetch)
+              (uri (hackage-uri "concurrent-split" version))
+              (sha256
+               (base32
+                "0i9gak7q3ay8g1kzq7dg0bs36bg88n7kwy3h1r6jrni7mz7jh05f"))))
+    (build-system haskell-build-system)
+    (properties '((upstream-name . "concurrent-split")))
+    (home-page "https://hub.darcs.net/thielema/concurrent-split")
+    (synopsis "MVars and Channels with distinguished input and output side")
+    (description
+     "This package provides MVars and Channels with distinguished input and
+output side around the standard concurrency communication channels that make
+the distinction clear and type safe.")
+    (license license:bsd-3)))
+
 (define-public ghc-commutative-semigroups
   (package
     (name "ghc-commutative-semigroups")