diff mbox series

[bug#60120,09/28] gnu: Add ocaml-hmap.

Message ID 20221216132527.2539-9-pukkamustard@posteo.net
State New
Headers show
Series gnu: Add ocaml-5.0. | expand

Commit Message

pukkamustard Dec. 16, 2022, 1:25 p.m. UTC
* gnu/packages/ocaml.scm (ocaml-hmap): New variable.
---
 gnu/packages/ocaml.scm | 26 ++++++++++++++++++++++++++
 1 file changed, 26 insertions(+)
diff mbox series

Patch

diff --git a/gnu/packages/ocaml.scm b/gnu/packages/ocaml.scm
index 7118f88318..6a7abed03c 100644
--- a/gnu/packages/ocaml.scm
+++ b/gnu/packages/ocaml.scm
@@ -2767,6 +2767,32 @@  (define-public ocaml-optint
 architectures.")
     (license license:isc)))
 
+(define-public ocaml-hmap
+  (package
+    (name "ocaml-hmap")
+    (version "0.8.1")
+    (source
+     (origin
+       (method url-fetch)
+       (uri "http://erratique.ch/software/hmap/releases/hmap-0.8.1.tbz")
+       (sha256
+	(base32 "10xyjy4ab87z7jnghy0wnla9wrmazgyhdwhr4hdmxxdn28dxn03a"))))
+    (build-system ocaml-build-system)
+    (arguments
+     `(#:build-flags
+       (list "build" "--tests" "true")
+       #:phases
+       (modify-phases %standard-phases
+         (delete 'configure))))
+    (native-inputs (list ocaml-topkg ocamlbuild opam))
+    (home-page "http://erratique.ch/software/hmap")
+    (synopsis "Heterogeneous value maps for OCaml")
+    (description
+     "Hmap provides heterogeneous value maps for OCaml.  These maps bind keys to
+values with arbitrary types.  Keys witness the type of the value they are bound
+to which allows to add and lookup bindings in a type safe manner. ")
+    (license license:isc)))
+
 (define-public ocaml-lwt
   (package
     (name "ocaml-lwt")