diff mbox series

[bug#60120,05/28] gnu: opam: Use OCaml 4.14 compiled version when building OCaml 5.0 packages.

Message ID 20221216132527.2539-5-pukkamustard@posteo.net
State New
Headers show
Series gnu: Add ocaml-5.0. | expand

Commit Message

pukkamustard Dec. 16, 2022, 1:25 p.m. UTC
* gnu/packages/ocaml.scm (opam)[properties]: Add ocaml5.0-variant.
  (opam)[propagated-inputs]: Move to inputs.
---
 gnu/packages/ocaml.scm | 11 ++++++-----
 1 file changed, 6 insertions(+), 5 deletions(-)
diff mbox series

Patch

diff --git a/gnu/packages/ocaml.scm b/gnu/packages/ocaml.scm
index 605baa801d..7abb31d183 100644
--- a/gnu/packages/ocaml.scm
+++ b/gnu/packages/ocaml.scm
@@ -960,11 +960,12 @@  (define-public opam
                                            "0j9abisx3ifzm66ci3p45mngmz4f0fx7yd9jjxrz3f8w5jffc9ii"))
          ("opam-repo-f372039d" ,(opam-repo "f372039db86a970ef3e662adbfe0d4f5cd980701"
                                            "0ld7fcry6ss6fmrpswvr6bikgx299w97h0gwrjjh7kd7rydsjdws")))))
-    (inputs
-     (list ocaml ncurses curl bubblewrap))
-    (propagated-inputs
-     (list ocaml-cmdliner ocaml-dose3 ocaml-mccs ocaml-opam-file-format
-           ocaml-re))
+    (inputs (list ocaml ncurses curl bubblewrap ocaml-cmdliner ocaml-dose3
+                  ocaml-mccs ocaml-opam-file-format ocaml-re))
+    (properties
+     ;; OPAM is used as a tool and not as a library, we can use the OCaml 4.14
+     ;; compiled opam until opam is compatible with OCaml 5.0.
+     `((ocaml5.0-variant . ,(delay opam))))
     (home-page "http://opam.ocamlpro.com/")
     (synopsis "Package manager for OCaml")
     (description