diff mbox series

[bug#60120,22/28] gnu: Add ocaml-uring.

Message ID 20221216132527.2539-22-pukkamustard@posteo.net
State New
Headers show
Series gnu: Add ocaml-5.0. | expand

Commit Message

pukkamustard Dec. 16, 2022, 1:25 p.m. UTC
* gnu/packages/ocaml.scm (ocaml-uring): New variable.
---
 gnu/packages/ocaml.scm | 31 +++++++++++++++++++++++++++++++
 1 file changed, 31 insertions(+)
diff mbox series

Patch

diff --git a/gnu/packages/ocaml.scm b/gnu/packages/ocaml.scm
index afad994d8d..d413d54f63 100644
--- a/gnu/packages/ocaml.scm
+++ b/gnu/packages/ocaml.scm
@@ -2842,6 +2842,37 @@  (define ocaml-eio-luv
 (define-public ocaml5.0-eio-luv
   (package-with-ocaml5.0 ocaml-eio-luv))
 
+(define-public ocaml-uring
+  (package
+    (name "ocaml-uring")
+    (version "0.4")
+    (home-page "https://github.com/ocaml-multicore/ocaml-uring")
+    (source
+      (origin
+        (method git-fetch)
+        (uri (git-reference
+               (url home-page)
+               (commit (string-append "v" version))))
+        (file-name (git-file-name name version))
+        (sha256 (base32
+                 "0k70y7nb2wrk2yql0pwnrhsp1x7k9ld4gd8iihbv6r34kcm3a5m1"))))
+    (build-system dune-build-system)
+    (arguments `(#:test-target "."))
+    (propagated-inputs
+     (list ocaml-cstruct
+           ocaml-fmt
+           ocaml-optint))
+    (native-inputs
+     (list ocaml-lwt
+           ocaml-bechamel
+           ocaml-logs
+           ocaml-cmdliner
+           ocaml-mdx))
+    (synopsis "OCaml bindings for Linux io_uring")
+    (description "OCaml bindings to the Linux io_uring kernel IO interfaces.")
+    (license
+     (list license:isc license:expat))))
+
 (define-public ocaml-lwt
   (package
     (name "ocaml-lwt")