diff mbox series

[bug#60120,07/28] gnu: Add ocaml-monolith.

Message ID 20221216132527.2539-7-pukkamustard@posteo.net
State New
Headers show
Series gnu: Add ocaml-5.0. | expand

Commit Message

pukkamustard Dec. 16, 2022, 1:25 p.m. UTC
* gnu/packages/ocaml.scm (ocaml-monolith): New variable.
---
 gnu/packages/ocaml.scm | 23 +++++++++++++++++++++++
 1 file changed, 23 insertions(+)
diff mbox series

Patch

diff --git a/gnu/packages/ocaml.scm b/gnu/packages/ocaml.scm
index 261de17dbb..58eef28558 100644
--- a/gnu/packages/ocaml.scm
+++ b/gnu/packages/ocaml.scm
@@ -8662,6 +8662,29 @@  (define-public ocaml-afl-persistent
 repeated forking and is much faster.")
     (license license:expat)))
 
+(define-public ocaml-monolith
+  (package
+    (name "ocaml-monolith")
+    (version "20210525")
+    (source
+     (origin
+       (method url-fetch)
+       (uri
+        "https://gitlab.inria.fr/fpottier/monolith/-/archive/20210525/archive.tar.gz")
+       (sha256
+        (base32
+         "1fcjpxspdksyrk2gmmk968s6fpkqlyn6zsg2rbz044f5slm39rcx"))))
+    (build-system dune-build-system)
+    (arguments `(#:test-target "."))
+    (propagated-inputs (list ocaml-afl-persistent ocaml-pprint ocaml-seq))
+    (home-page "https://gitlab.inria.fr/fpottier/monolith")
+    (synopsis "Framework for testing an OCaml library using afl-fuzz")
+    (description "Monolith offers facilities for testing an OCaml library (for
+instance, a data structure implementation) by comparing it against a reference
+implementation.  It can be used to perform either random testing or fuzz
+testing by using the @code{afl-fuzz} tool.")
+    (license license:lgpl3+)))
+
 (define-public ocaml-pprint
   (package
     (name "ocaml-pprint")