diff mbox series

[bug#60120,18/28] gnu: Add ocaml-bechamel.

Message ID 20221216132527.2539-18-pukkamustard@posteo.net
State New
Headers show
Series gnu: Add ocaml-5.0. | expand

Commit Message

pukkamustard Dec. 16, 2022, 1:25 p.m. UTC
* gnu/packages/ocaml.scm (ocaml-bechamel): New variable.
---
 gnu/packages/ocaml.scm | 24 ++++++++++++++++++++++++
 1 file changed, 24 insertions(+)
diff mbox series

Patch

diff --git a/gnu/packages/ocaml.scm b/gnu/packages/ocaml.scm
index 7fbaed69ad..3bceb9c3d3 100644
--- a/gnu/packages/ocaml.scm
+++ b/gnu/packages/ocaml.scm
@@ -3607,6 +3607,30 @@  (define-public ocaml-benchmark
 is used to determine whether the results truly differ.")
     (license license:lgpl3+)))
 
+(define-public ocaml-bechamel
+  (package
+    (name "ocaml-bechamel")
+    (version "0.3.0")
+    (home-page "https://github.com/mirage/bechamel")
+    (source
+      (origin
+        (method git-fetch)
+        (uri (git-reference
+               (url home-page)
+               (commit (string-append "v" version))))
+        (file-name (git-file-name name version))
+        (sha256
+         (base32 "1x7sf45iy5dzx7kknbkkvpna42rcwpj5p55y0nqsg2fb4srj0b1q"))))
+    (build-system dune-build-system)
+    (arguments `(#:package "bechamel"))
+    (propagated-inputs (list ocaml-fmt ocaml-stdlib-shims))
+    (synopsis "Yet Another Benchmark in OCaml")
+    (description
+     "BEnchmark for a CHAMEL/camel/caml which is agnostic to the system.  It's a
+micro-benchmark tool for OCaml which lets the user to re-analyzes and prints
+samples.")
+    (license license:expat)))
+
 (define-public ocaml-batteries
   (package
     (name "ocaml-batteries")