diff mbox series

[bug#60120,27/28] gnu: Add ocaml5.0-dot-merlin-reader.

Message ID 20221216132527.2539-27-pukkamustard@posteo.net
State New
Headers show
Series gnu: Add ocaml-5.0. | expand

Commit Message

pukkamustard Dec. 16, 2022, 1:25 p.m. UTC
* gnu/packages/ocaml.scm (ocaml5.0-dot-merlin-reader): New variable.
---
 gnu/packages/ocaml.scm | 13 +++++++++++++
 1 file changed, 13 insertions(+)
diff mbox series

Patch

diff --git a/gnu/packages/ocaml.scm b/gnu/packages/ocaml.scm
index 1b3e51001f..dc824626fd 100644
--- a/gnu/packages/ocaml.scm
+++ b/gnu/packages/ocaml.scm
@@ -5405,10 +5405,23 @@  (define-public ocaml-dot-merlin-reader
     (arguments '(#:package "dot-merlin-reader"
                  #:tests? #f))          ; no tests
     (propagated-inputs (list ocaml-merlin-lib))
+    (properties `((ocaml5.0-variant . ,(delay ocaml5.0-dot-merlin-reader))))
     (synopsis "Reads config files for @code{ocaml-merlin}")
     (description "@code{ocaml-dot-merlin-reader} is an external reader for
 @code{ocaml-merlin} configurations.")))
 
+(define-public ocaml5.0-dot-merlin-reader
+  (package-with-ocaml5.0
+   (package
+     (inherit ocaml-merlin-lib-500)
+     (name "ocaml-dot-merlin-reader")
+     (arguments '(#:package "dot-merlin-reader"
+                  #:tests? #f))         ; no tests
+     (propagated-inputs (list ocaml5.0-merlin-lib))
+     (synopsis "Reads config files for @code{ocaml-merlin}")
+     (description "@code{ocaml-dot-merlin-reader} is an external reader for
+@code{ocaml-merlin} configurations."))))
+
 (define-public ocaml-merlin
   (package
     (inherit ocaml-dot-merlin-reader)